No sound on my PS3 HDMI

This topic is locked from further discussion.

#1 Posted by son-of-a-gun707 (445 posts) -

Okay so I have my PS3 for about a month now, I didnt have any problems with it untill today. My only game is Killzone 2 and I finished the game. So today i wanted to play again but I dont have sound.. its completely gone.. but with normal tv i have sound so the problem is with the PS3. I did notice sometimes some audio problems and that the screen went black for about 2 seconds.. so I use a HDMI cable. I read more people have troubles with a HDMI cable on the PS3, but i cant find what to do about my audio problem.. can somebody here help me?

MELO 4 MVP

#2 Posted by raven_squad (78438 posts) -
I really don't know as I haven't experienced the problem first hand. Have you tried a different HDMI cable, or tried the PS3 on another tv? Also, you can try configuring the audio settings separately to make sure your PS3 is outputting sound via HDMI.
#3 Posted by HarshGamer (2822 posts) -
Go in Sound Settings and make the HDMI the input for sound.
#4 Posted by lukas1051 (687 posts) -

Go into display settings and set your PS3 to HDMI output. It will then ask you to set Audio Output Settings, so set that to HDMI as well. I've had this problm before and that's how I fixed it. If that doesn't work, I don't really know.

#5 Posted by thanatosdk (1 posts) -

Okay so I have my PS3 for about a month now, I didnt have any problems with it untill today. My only game is Killzone 2 and I finished the game. So today i wanted to play again but I dont have sound.. its completely gone.. but with normal tv i have sound so the problem is with the PS3. I did notice sometimes some audio problems and that the screen went black for about 2 seconds.. so I use a HDMI cable. I read more people have troubles with a HDMI cable on the PS3, but i cant find what to do about my audio problem.. can somebody here help me?

MELO 4 MVP

son-of-a-gun707

Hello

Just to let you know, I have the exact same problem - and it started to happen just around the time that you posted this topic. I haven't been able to solve this problem yet, so please let me know if you figure out what the cause of the problem is.

/Thanatos

#6 Posted by cuso26 (2 posts) -
I'm actually having this same problem. I have an extremely weird way of fixing it too. I go to PS Home and when it starts downloading the patch for it, I cancel it and magically my sound works, it's the strangest thing. In case it's relevant at all, I'm running the PS3 on a Sony KDL-40XBR6 TV. Anyone found a resolution to this issue yet? It's intermittent, but damn if it's annoying.
#7 Posted by jimm895 (7703 posts) -

I have had this happen a few times in past two plus years and found that the problem I had was because one side of HDMI cable had come lose. After snugging the cable connection all was fine.

#8 Posted by raider1648 (1691 posts) -

This happened to me once. I thought it was because I constantly switched the HDMI from my ps3 to the direcTV receiver. I started playing cod4 online and after a while the sound raondomly came back.

#9 Posted by eo_the_shaman (1800 posts) -

um something happens to me to but only when istart a game the sound for the game doesnt come on, i just quit the game and restart it and the sound works..maybe restart the ps3 or change your hdmi slots

#10 Posted by cuso26 (2 posts) -
I've done all the HDMI slot fiddling I can and nothing changes things. Is it possible it's the cable I'm using? It's just very strange that sometimes it works, and others it doesn't and that if I do certain things on the PS3 interface, it will magically start to work again. Very odd.
#11 Posted by son-of-a-gun707 (445 posts) -

lol i fixed my problem, i switch my TV to standby and then turn it back on and the sound is back.

#12 Posted by dabomb224 (1 posts) -
I just updated to the newest FW (with the different logo and the sparkly backgorund) and began having the same problem. Randomly, sometimes when I turn on my ps3, the sound won't work. Once it does stop working, the only way to get it back is to restore my system defaults (which is a severe pain in the ass). Has there been any known issues mentioned with the new FW that could account for this?
#13 Posted by KLONE360 (1119 posts) -

Go to playstation.com and search the faqs and forums and email playstation support or call them its free.

#14 Posted by GeneralHawx (1853 posts) -

Go into display settings and set your PS3 to HDMI output. It will then ask you to set Audio Output Settings, so set that to HDMI as well. I've had this problm before and that's how I fixed it. If that doesn't work, I don't really know.

lukas1051
^This
#15 Posted by crossaxe (124 posts) -

I have a similar problem i have hdmi hooked up for a while now and it looks great but it is making my sound worse ihave tried using automatic audio setup but the sound is still muffled and noisey anyone had same problem

#16 Posted by NickLovin22 (69 posts) -

the only solution i can offer it to go to sound settings and fiddle around. try switching the hdmi ends around. for example: take the end that is plugged into the ps3 and put it in the tv, and the end in the tv, put it in the ps3. hope this helps

#17 Posted by wrench12 (1 posts) -
TBH, this just happened to me, i got all panic.ed, but i just went onto PSHome and mpoved my cursor around, i heared a clicking with the screens changing, i quite PSHome and went to home screen, and HALELUYA i had sound, MW2 Resurgance pack here i come, lol, home this helped, i tried averything but this. thought id have a go and it worked. WOOP
#18 Posted by johnfatz1 (1 posts) -

lol i fixed my problem, i switch my TV to standby and then turn it back on and the sound is back.

son-of-a-gun707
Same here! Thanks man!
#19 Posted by CaptainCrazy (6856 posts) -
How much did you pay for that HDMI cable? Is it one of those no name cheap brands? In most cases devices only need basic hdmi but the PS3 seems to require higher quality cables as I have had the same problems so I'm speaking from experience. Once I switched to a sony branded PS3 hdmi cable (version 1.3b revision 2 i believe), then those problems all went away.
#20 Posted by tre_los (1 posts) -
Hello i have no soynd on my ps3 i dont know why..... Yesterday i saw a movie on ps3 and everything was perfect... today i am trying to play a game and i dont have sound ..... Any ideas???
#21 Posted by Manuel24 (46 posts) -

[QUOTE="son-of-a-gun707"]

lol i fixed my problem, i switch my TV to standby and then turn it back on and the sound is back.

johnfatz1

Same here! Thanks man!

THIS.

got the sound problem too, after 15 min of reading I tried to turn off my tv, yep then turn it back on and got the sound.

#22 Posted by BPoole96 (22813 posts) -

Go to your sound setting and change the input to HDMI

#23 Posted by iPhantom93 (1 posts) -
Try the setting first.... If still fail... Try to turn the tv to standy for a while , then turn back on. It should work. If still fail, contact professional ...
#24 Posted by AtlSteel (4 posts) -
Sony missed the whole iPod wave entirely even though they had the brand (Walkman), the content, the distribution, and the technology. Their ex-CEO said it was because of poor communication between the groups. Now I have to turn my Sony TV off and on and hope it will magically start playing the sound from my Sony PS3. Not cool.
#25 Posted by romana86 (1288 posts) -

[QUOTE="johnfatz1"][QUOTE="son-of-a-gun707"]

lol i fixed my problem, i switch my TV to standby and then turn it back on and the sound is back.

Manuel24

Same here! Thanks man!

THIS.

got the sound problem too, after 15 min of reading I tried to turn off my tv, yep then turn it back on and got the sound.

Just wanted to say I just got this problem and doing this fixed it for me as well! Which is very strange - I didn't think the problem was with my tv because the sound worked fine on cable, xbox360, and gamecube, but not ps3??? And I'd tried fixing the hdmi cable to make sure it wasn't loose, restarting the system and the tv, and nothing worked until I did this for some reason.

Odd as hell.

#26 Posted by dann55 (1 posts) -
i dont believe any of this because yes it works when i use the simple componet but i try to use hdmi sound is gone., ive tried all the above mentioned and nothing.
#27 Posted by BelgianFanboy (1 posts) -
Fory anyone who still has this problem with the HDMI-cable: Menu >> Settings >> Sound settings : Make sure that; - Audio-Output is on HDMI, let it search AUTOMATICALLY, then confirm - Plural Sound-Output is ON I had this problem myself, and after this my sound worked on both the PS3 menu itself and in-game. I'm sorry if this doesn't resolve your problem.
#28 Posted by whitenore (0 posts) -
OK, I know this is late, but if anyone is still having problems with this, ensure that when you setup your audio, that your TV settings and ps3 settings are alike. When I automatically set my audio it told me that I had a PCM audio connection. So I went to my TV"s audio menu and selected PCM from Dolby digital and booyah I was back in business hope this helps you guys out that still have this problem.