Netflix not usable on launch?

This topic is locked from further discussion.

#1 Edited by MirkoS77 (8188 posts) -

Does Netflix supposed to work on launch? I've tried signing up, and get to first/last name, email, and password. Then it tells me, "There was an error creating your account. Please check that all fields are filled out correctly and try again". This occurs almost instantaneously so I have a feeling nothing is even being sent to any server.

All the fields are filled out and correct, but in asking me for my password it almost looks as if they're asking for my gmail password, and I'm not going to give that away. I believe it's asking for me to make one up but it keeps giving me the above.

Does Netflix not yet work?

#2 Posted by joseph_mach (3623 posts) -

I installed the app yesterday and it's been working just fine for me.

#3 Posted by Sophette (509 posts) -

I've been watching Netflix all morning. I couldn't sign in yesterday when the network was down, but by midnight it was all fine. Amazon Instant video works too if you're curious.

#4 Posted by MirkoS77 (8188 posts) -

Stupid me. I had signed up for and cancelled NF about 5 years ago, and tried and old email and password that I might have used back then, and it worked. I forgot they store user info even though it's been cancelled.