help!!!!! no sound through HDMI

This topic is locked from further discussion.

#1 Posted by SiKh22 (4661 posts) -
I just turned on my ps3, its connected Via HDMI. I can get a picture but with no sound. I tired the other HD inputs no sound, i tired another HDMI calbe still no sound. THe sound only works through the calbes sony gave, compoent. I have a Sharp LCD 32'', it was working fine last night, until today, anyone know what the issue is?
#2 Posted by thageneral3 (1929 posts) -
you need to go to settings on the XMB and SOUND SETTINGs and have them set to HDMI... When you switch outputs you neeed to change the display settings AND the sound settings
#3 Posted by SiKh22 (4661 posts) -
i did, i've had the ps3 since November. Ok, it started to work again. Is their something wrong with the PS3? I mean it wasn't working 10 minutes ago and now the sound is coming. I think if this happens again, I'm going to call sony.
#4 Posted by thageneral3 (1929 posts) -
I don't know. What i explained is the only reason I could think of. It could be the ps3, the cable, or even the TV. Hopefully it doesnt happen again.
#5 Posted by SiKh22 (4661 posts) -
It's prolly just me but the XMB scrolling noise. As you go side to side on the XMB sounds a lot quiter then when ur playing a gmae. that Clicking noise is not that loud as to when you load a game, the PS3 sound is louder.
#6 Posted by Thomas-Crown (30371 posts) -
Maybe you can try a auto reset. Hold the power button down and wait until you hear 2 beeps. The PS3 will automatically search your input connections. hope it works.
#7 Posted by SOedipus (6805 posts) -
The console has to adapt everytime you switch cables. Either hold the reset button when the console is off until you hear a couple beeps or go to audio options, HDMI then auto-detect (or whatever it's called).
#8 Posted by SiKh22 (4661 posts) -
no it works now, i don't know why it works all of the sudden. Mabye its cause i tired reseting it, but i did it like 4 times then went to my compoent calbes then back to my HDMI and it still didn't work. THen i just gave up and was about to call sony, and tired it once again and it worked! :) like magic
#9 Posted by cooljojosarkar (34 posts) -

Sorry to jack your thread but I now have te same problem. I have tried factory resets, holding the stanby button for 5 secs, changing audio settings to hdmi. Nothing works.

I only get sound from digital optical cable

#10 Posted by jimm895 (7703 posts) -

Sorry to jack your thread but I now have te same problem. I have tried factory resets, holding the stanby button for 5 secs, changing audio settings to hdmi. Nothing works.

I only get sound from digital optical cable

cooljojosarkar

The auto-detect feature doesn't work for the sound settings, it only works for video, and when using the AV connection it will only auto-detect composite settings you have to manually select component from the XMB once you have the video signal.

As for the problems you guys are having with sound, you may have a HDMI cable that has slightly pulled out of it's connection only on one side that will allow the video signal to go through but the sound connection isn't there. I have had this happen a couple of times in the past year or so, even happened on the sattelite reciever one of those times.

#11 Posted by blitz_rock_1 (37 posts) -
I have the same problem. I'm using my PS3 with a Nyko HDMI cable that i got about 2 weeks ago. It worked fine the first week but there has been no sound since then. I had ordered the cable via newegg. I've also since gone to Circuit City to pick-up the same HDMI and neither HDMI produce sound. The HDMI cable is plugged in correctly (to both the TV & PS3) and i've gone through the PS3 system settings and the sound is set up to go through HDMI & i've also done a reset with the PS3, none of which have worked. Any other ideas?
#12 Posted by bubskie65 (1 posts) -
sorry i couldnt come to the rescue earlier, but however, i found the solution for you guys!!!! you actually have to go into the sound setting/hdmi/ then rather then choosing automatic, go to manual control. then after just select all of the types of "sound type", unless if u know exactly what type of sound setting your TV uses. thats what i did and it works. note: it will say that it might damage your speakers. it just went ahead and did it anyways- no problems.
#13 Posted by Trippinstarr (1 posts) -
OMG!!!! bubskie65 You Just Saved Us!!!! Thank You Thank You Thank You!!!!
#14 Posted by jaden_xp (1 posts) -
ok, i figured mine out. under sound settings, there is an option that is called audio mullti-out put or something like that, i enabled mine and it worked perfectly. the effect should work backwards too so if it is enabled, un-enable it