serious lag from Mirror's edge

This topic is locked from further discussion.

#1 Posted by eo_the_shaman (1800 posts) -

So im playing Mirrors edge and i keep getting lag in the big escape levels IE Ropeburn. im normally getting 40-60 fps but right when the actually escape part starts i drop to 15 then to around 4. im running dual GTX 660 SLI 8Gbs ddr3 1333 RAM and a 3.7ghz i7 LGA 2011 processor. i havent even touched the overclocking options in the EVEGA Precision X program just adjusting the fan to full power, and both cards dont exceed 40 degrees celsius. i just updated the graphics drivers and its still happening i just dont understand how a 2009 game can cause so much lag when i can run battlefield 3 at 40 FPS on ultra settings like its cool. any thoughts ladies and gents?

#2 Posted by Inconsistancy (8094 posts) -
Do you have "PhysX" enabled, and if so, is it running on the GPU or CPU?
#3 Posted by iwilson1296 (2214 posts) -

So im playing Mirrors edge and i keep getting lag in the big escape levels IE Ropeburn. im normally getting 40-60 fps but right when the actually escape part starts i drop to 15 then to around 4. im running dual GTX 660 SLI 8Gbs ddr3 1333 RAM and a 3.7ghz i7 LGA 2011 processor. i havent even touched the overclocking options in the EVEGA Precision X program just adjusting the fan to full power, and both cards dont exceed 40 degrees celsius. i just updated the graphics drivers and its still happening i just dont understand how a 2009 game can cause so much lag when i can run battlefield 3 at 40 FPS on ultra settings like its cool. any thoughts ladies and gents?

eo_the_shaman

i think it's a a physx issue, ya have to do something like download thenewest physx update file and install it, then go to the mirrors edge install directory, go into binaries folder, delete physxcore.dll and physxdevice.dll, and also delete the physxlocal directory, they are probably older physx files and by deleting them it will make the game use the newest installed physx. 

#4 Posted by eo_the_shaman (1800 posts) -

Do you have "PhysX" enabled, and if so, is it running on the GPU or CPU? Inconsistancy

yes i have physx enabled...and i really dont know i just clicked enable physx in video option xD

 

and wilson i did as you said im downloading the update right now lets hope it works, thanks for the information guys/gals!

#5 Posted by eo_the_shaman (1800 posts) -

worked like a charm no lag what so ever

#6 Posted by iwilson1296 (2214 posts) -

Fantastic :)