This topic is locked from further discussion.

Avatar image for PredatorRules
#1 Posted by PredatorRules (10713 posts) -

Hi, I've encountered a problem using my headset, it's Razer Megalodon, I'm using ASUS H81M-A mobo and I get "USB device is not recognized" everytime.

I've tried to plug it to front and rear USB hubs and even into USB3 ones and still nothing.

I've updated mobo and everything; It worked just fine on my last PC and it still working fine on other computers at home. I wonder what's the problem.

Any ideas?

Avatar image for lostrib
#2 Posted by lostrib (49999 posts) -

do those ports work with other USB devices?

Avatar image for PredatorRules
#3 Posted by PredatorRules (10713 posts) -

Yes, I've got my flashdrive working and my Xbox 360 Wireless controller plugged in and working as well on all USB ports.

Avatar image for lostrib
#4 Posted by lostrib (49999 posts) -

does it need drivers/software to be installed?

Avatar image for PredatorRules
#5 Posted by PredatorRules (10713 posts) -

nope, it's plug and play and the firmware inside of it is already updated so...

Avatar image for lostrib
#6 Posted by lostrib (49999 posts) -

@PredatorRules said:

nope, it's plug and play and the firmware inside of it is already updated so...

hmmm, don't know then. Contact razer?

Avatar image for PredatorRules
#7 Posted by PredatorRules (10713 posts) -

Yeah I think I should; I'm so close giving up and just buy myself new Headphones + Mic

Avatar image for kraken2109
#8 Posted by kraken2109 (13271 posts) -

Razer aren't exactly famous for build quality.