Max Payne and Vista

This topic is locked from further discussion.

#1 Posted by zebruter (182 posts) -

has anyone had trouble with cut-scene sounds in max payne using vista? if so, could you please pass along a solution?

i installed the game and the sounds are fine during game play (guns firing, junkies gasping their last breaths, etc.), but i get no sound at all during the intro scene with the helicoptor and police cars and during the graphic novel type cutscenes. i'm enjoying the game, but would like to fully experience the cutscenes. if it makes a difference, i have 32-bit vista (home premium) and just on-board sound (realtek). would running the game in a compatability mode help? if so, which one? thanks in advance for any help here.

also does anyone know of any mods to change the shape of the crosshair? i find the little white dot somewhat annoying.


#2 Posted by gotcha455 (2611 posts) -

I'm using 32 bit Vista home premium, and unfortunately the demo has given me the same results.

The good news is, Max Payne 2 plays great!

#3 Posted by Shatilov (4117 posts) -
u must install Creative Alchemy ( google it ) it is the solution for all the EAX problems in Vista . it have 2 files called ( dsound.dll & dsoundlog ) , copy them & paste them in the Game's Directory with the Game's exe .
#4 Posted by Captain__Tripps (4521 posts) -
Does that work even if you dont have a creative sound card?
#5 Posted by The_PC_Gamer (2910 posts) -
I've had the exact same solution. Google it, and there is a way to fix it using a user-created patch.
#6 Posted by Uberbadassmufuh (1006 posts) -

"A voice came to me as if in a dream.... 'Max, you're in vista now, the old directsound API's go nowhere'... it was funny as hell... I was in vista... it was the worst thing I could possibly think of."

*this parody comes from a happy vista user using ALchemy for his older games and is in no way meant to imply that Vista is anything less than a superb gaming OS.

#7 Posted by zebruter (182 posts) -

i don't have a creative soundcard but i tried something similar to the creative alchemy suggestion.

linked here:

i tried method 1 since the other way requires installation of the game to a non-program files directory. method 1 didn't work for me, but maybe it will for others. if anyone has tried method 2 and it has worked for them, please let me know. i've uninstalled MP and will probably try it (eventually...).


#8 Posted by Captain__Tripps (4521 posts) -

Method 1 doesn't work. Im sure method 2 would, since it involves converting the audio... Also a non-program files install isn't neccessary, just says it simplifies it. Just need to run your command prompt as admin.

#9 Posted by Behelit42 (1 posts) -
!! Ultimate Max Payne Vista Sound Patch !!

Hello everyone.

I'm a big fan of the original Max Payne because of the mods, so in light of the movie coming out and the imminent release of "The Real World", I decided to fire up the game in Vista 64bit. Needless to say, I was despondent when I found out that the sound was essentially nonexistent and that there was no official patch to fix it. But I googled around for a home brew fix and found this forum and the 3D Relms forum.

The sound fix that Darkje has created is excellent, it restores the "stock" game sounds and music quite nicely. However, it has the unfortunate flaw of not being able to play mods. Then I noticed Maddieman's post about fixing/repacking the game sounds, but I couldn't get it to work either. I kept getting the same annoying "Exception in startupInit: Directory data not found." message that tombenton had. Even when I got it to where it SHOULD work, I couldn't get both the "stock" sound AND the mods working at the same time. It was like tug of war or something. Then I started to analyze the problem.

Darkje's patch is a little sloppy in that it combines the files from all 6 *.ras files and then just leaves them there. When there is a /data directory there, the game thinks: "oh, there is a mod in that /data directory. It gets top priority.". So no matter what mod you pick in the "Choose Customized Game" menu, it will load what is in the /data directory instead. That's the flaw, but it's also part of the solution.

With a little experimentation, I was able to improve on Darkje's fix and made a procedure that not only permanently fixes the game's "stock" sound, but allows you to easily load mpm / mod files as well. Mods can be loaded, played with working sound, and unloaded with relative ease.

I found out that 3 of the *.ras files only contain level information and thus do not need to be decompressed. So rather then dumping all 6 *.ras files into a single data folder, my patch extracts and converts only the x_data, x_english, and x_music *.ras files individually. Once each *.ras file is moved and decompressed in it's own separate directory, all sounds and music are converted. The patch then repacks all *.ras files one by one, which replace the originals. At this point the "stock" game runs perfectly, everything should be working just like with Darkje's script. But if you try loading a mod in the normal way,"Choose Customized Game", nothing happens. Also like Darkje's script.

But unlike Darkje's script, my fix offers a workable solution for loading mod files. There is no /data folder now. Remember what I said earlier about the /data folder taking priority? Well, now that it's gone, *.mpm mod files can be extracted and converted in exactly the same way that Darkje's script converts *.ras files. There is one small drawback to this method. You can only load one mod at a time, literally. If you try to put more then one *.mpm / mod file in the MaxPayne folder, the script will combine all the decompressed files into the /data folder... and that's bad. However, you can easily switch mods by using a batch file that loads and unloads mpm / mod files. I have included the full patch and instructions below...

Download the here: *COPY AND PASTE URL*

Fixing the stock Sounds & Music: *Do This First!*

Install Max Payne to the c:MaxPayne directory, no spaces. This step is very important, because the patch works out of c:MaxPayne.

Unzip the "" into the c:MaxPayne directory. If for some reason you want to save the original ras files, backup x_data.ras, x_english.ras, and x_music.ras now. Those are the only files affected.

Run the sound_patch.bat file. You will see a lot of "Premature EOF" and "syntax" messages, just like Darkje's script, but everything is OK. When the patch is done, the batch file will ask you to remove 4 directories and then delete itself. Just answer (Y)es 4 times. You can stop at this step if you don't want to run any mods.

Loading mpm / mod files:

Copy or Move the mpm / mod file into the c:MaxPayne directory. It is important that only one mpm / mod file is loaded at a time.

Run the sound_patch.bat file. You will see a lot of "Premature EOF" and "syntax" messages, just like before, but everything is OK. When finished, simply run the game and the mod will load automatically.

If you want to load a new mpm / mod file, simply run the sound_patch.bat file again to unload the old file. Move the old mpm / mod to a different directory and repeat from step 1. If you want to play "Original Mode", simply leave the mpm / mod file unloaded and the game will load normally.

If you did everything correctly, then Max Payne will have fully working sound and music, for both stock mode and game mods. I have tested this procedure several times on 64bit Vista and can say for sure that it works flawlessly. I have even tested several mods, including Katana and the Real World Demo, and they work flawlessly. The only mod I can't get to work is Kung Fu 3.0, it seems to hang before anything loads. However, most mods work just fine. Even the menu screen music in Katana plays perfect. If Vista has been the bane of your Max Payne existence, then you are going to love this fix.

Special thanks to Darkje and Maddieman for doing most of the ground work.

#10 Posted by Otte256 (6 posts) -

Dude, THANK YOU SO MUCH for this fix. You are the man. I was so disapointed when I found out that my sound was screwing up, thanks to you I can play through MP 1 + 2 in time for the movie! WEWT!


#11 Posted by RJtheShadow (440 posts) -

I've done all the steps that were described, but when it was all done, I kept getting this error:

Exception in engineInit: File\DATA\INPUT.TXT not found

As the stupid wiseguy I am, I created the file in the data directory, whereas it said that certain file is corrupt instead of not found.
Can somebody please hand me the file, or tell me what I should do?

I'm a dimwit on this whole techie thing.
So a more forward sollution that doesn't require any techie knowledge (or long, agonising steps that are bound to go wrong at a point) would be very very, VERY appreciated...

I'm already happy Darkje's sollution made me able to play MP again, but once you've had a taste of Katana, you don't want anything else for MP. =P

So, uh... a distress call for help from a dimwit?

#12 Posted by RJtheShadow (440 posts) -


#13 Posted by LilTorch (2 posts) -
I downloaded Max Payne through steam, and it will only let me install it in one directory (so the tool kit wouldn't work, right?) and whenever I try the creative alchemy fix, it just tells me I don't have the right product. Unless I'm doing something wrong, I can't find a fix. I have Vista, by the way.