GTA 4 Graphic Warning GTX 770

This topic is locked from further discussion.

Avatar image for DasBrain56
#1 Posted by DasBrain56 (25 posts) -

So I tried to play GTA 4 with the GTX 770 4gb I bought back in November. When I try to adjust the graphic settings it says

"Warning: Your graphics settings are near,or exceed,the suggested resource limits for your system. It is recommend that you reduce your graphic settings in order to run the game optimally" and it wont let me adjust any setting and everything is set to lowest setting. Also all the loading GTA art is gone and says I need falsh player 9 even though flash 9 is installed. Anyway to fix this?

It really bugs me that after 5 years this game still has problems.

Avatar image for C_Rule
#2 Edited by C_Rule (9816 posts) -

You using Lucid Virtu? Is your monitor plugged directly into your GPU?

Avatar image for DasBrain56
#3 Edited by DasBrain56 (25 posts) -

Yeah I checked my monitor, its plugged in correctly, I played a little far cry 3 just to make sure my card was working fine. I'm not using any kind of special mods or anything. This is the steam version.

Avatar image for Nick3306
#5 Posted by Nick3306 (2801 posts) -

This is a common problem with GTA4 and higher memory GPU's. Right click on GTA4, select properties, then launch options and copy and paste this into the field that comes up

-nomemrestrict -norestrictions

Avatar image for insane_metalist
#6 Posted by insane_metalist (7621 posts) -

This thread should fix your problem.

Avatar image for DasBrain56
#7 Posted by DasBrain56 (25 posts) -

I've decided to reinstall GTA 4 and will try your solutions, thanks for the help guys. I'll post back and let you know if the problem is fixed.

Avatar image for DasBrain56
#8 Edited by DasBrain56 (25 posts) -

Thank you Nick3306, your solution worked. The error messaged still appeared but at least I was able to change the graphic settings to max.

Avatar image for _SKatEDiRt_
#9 Posted by _SKatEDiRt_ (2727 posts) -

Ive had so many problems with gta 4. its complete crap. Right now its not even working and i cannot find a solution.

i bought the DLC and ballad and lost wont even startup. its a ******* joke

Avatar image for kitty
#10 Posted by kitty (115300 posts) -
@_SKatEDiRt_ said:

Ive had so many problems with gta 4. its complete crap. Right now its not even working and i cannot find a solution.

i bought the DLC and ballad and lost wont even startup. its a ******* joke

does it crash before it gets to the first screen with words? I had that problem and oddly msi afterburner was the cause. A re-install of afterburner and reboot fixed it. I recently had to revert back to an older version of afterburner, the newest one doesn't work on any game for me.

Avatar image for Cwagmire21
#11 Edited by Cwagmire21 (5896 posts) -

Ya the GTA IV port was pretty crappy.

The only issues I've had is with the social club fortunately.

Avatar image for wis3boi
#12 Posted by wis3boi (32498 posts) -

@Cwagmire21 said:

Ya the GTA IV port was pretty crappy.

The only issues I've had is with the social club fortunately.

all my problems went away when i ditched my hard copy for a steam copy and removed Xlive from the game

Avatar image for _SKatEDiRt_
#13 Posted by _SKatEDiRt_ (2727 posts) -

@2ndwonder: I do have that installed. thanks ill give that a try!!!!