Dungeon Siege - Windows 7?

This topic is locked from further discussion.

#1 Posted by Chronic276 (99 posts) -

Hey all,

I've just gone and bought Dungeon Siege cheap with no research at all checking if it works on Windows 7. I've been looking for a fix for it all morning. I've gone over a few things such as changing the Video Driver for the game, running it in compatibility mode, i read somewhere I should try downloading Direct X 9.0c. But I can't download that because I have a newer version. Does anyone have any idea how I could get this game working?

Any help would be appreciated!

#2 Posted by RobertBowen (4094 posts) -

I also had some problems getting the game to run, but managed to do it eventually, and I have Win 7 64-bit, Intel CPU and an Nvidia gfx card.

Don't install the game under Program Files, as this can lead to issues with quite a few older games. Instead, install to a separate directory on your hard drive. I can't remember whether or not I set a compatibility mode - it might run without it. If not, try Win XP and maybe 'run as admin'.

Anyway, run the game's executable directly from the installation folder, and don't use the desktop shortcut.

That's how I got it working. You may also have to tweak the resolution/video settings to get it to run properly. Legends Of Aranna also works on Win 7, including LAN play.

#3 Posted by Stream_Beta (352 posts) -

Well, I did do a LAN of Dungeon Siege 1 & 2 last year all on Win7 computers. So it does work. I feel like we played in compatibility mode of Windows XP and ran as administrator. It took a little configuration to get it to work. I mean we even got quite a few mods to work also.

#4 Posted by Chronic276 (99 posts) -
Thanks a bunch for the replies! Appreciate it. I'll check it out once I get home from work and see if it helps and get back to you. Thanks a bunch!
#5 Posted by Chronic276 (99 posts) -

Still no luck with this, keep getting the same error;

Error, fatal exception occured (can this object be used in this manner?)

HResult = -2147319779


cInvokeMethod2 :: Invoke

Any ideas?

EDIT: Simple fix. Run in Vista compatable mode. Something I would have never tried without stumbling on it by accident when putting it into XP SP2!

#6 Posted by Chronic276 (99 posts) -
Scratch that, still having problems, uninstalled now and I'll just keep it in my drawers. Complete waste of money, pissed about with it for the full day, next time more research is required before I go ahead and buy an older game. Shame I'm having the same problem with Far Cry 2 crashing when I choose a character to start a new game with too..