#1 Posted by FelipeInside (24621 posts) -

Well, looks like the new website is up and going, or is it? I sometimes have trouble loggin on but I'm sure the tech heads are working round the clock to fix it all up.

On that note, can anyone upload an image for their profile picture? My button doesn't seem to do anything.

#2 Posted by bonafidetk (3812 posts) -

I dont believe this can be the final forum. It looks... basic to say the least.

#3 Edited by JigglyWiggly_ (23150 posts) -

you won the race

i can't change my avatar either

i am kinda happy that sigs are disabled by default though

#4 Posted by BSC14 (3263 posts) -

Sup guys....

#5 Posted by Arthas045 (4860 posts) -

I give it a 4.........

#6 Edited by Sleepyz (3741 posts) -

I don't get why sites change things like this. There was nothing wrong with the forums before and this one was very slow to log-in.

Hope they add color to background this is very dull.

#7 Edited by NeoEnigma (195 posts) -

Took the site about a minute to process my username and password. What the crap.

I don't mind the design. I prefer the responsive width. Restricting screenshots to 800px wide was pretty poor. Let's test something...

Oh. Nevermind. Pressing the image button doesn't do anything.

#8 Posted by Elk (471 posts) -
#9 Posted by Baranga (14217 posts) -

I had a nightmare about these new boards last night. I suppose that's because it was the last site I visited before going to sleep. I dreamed that someone posted an obituary for biggest_loser and I couldn't upload my Katy Perry avatar and sig. Which I still can't because I'm too lazy to use the above fix.

That top posters panel sure is useful...

Where is the post preview button?

#10 Edited by IxX3xil3d0n3XxI (1508 posts) -

Do not like the new layout. I can see it being slow since its first day and all, but it looks bad.

#11 Edited by FelipeInside (24621 posts) -
#12 Edited by Elk (471 posts) -

@FelipeInside: Only text sigs seem to work right now. I've looked at it and it doesn't seem like something that can be fixed with script as their servers aren't sending the sig to the browser.

#13 Posted by FelipeInside (24621 posts) -

@Elk said:

@FelipeInside: Only text sigs seem to work right now. I've looked at it and it doesn't seem like something that can be fixed with script as their servers aren't sending the sig to the browser.

Thanks again, guess we have to wait for them to iron out the bugs.

One last question if anyone knows. Is there a way to see if someone has posted a new comment on a topic I've posted before? I used to check my contributions page on the old site and the "post number" would change depending how many new posts there were, so I could tell if there was an update or not.

I can't seem to find that here. I have the contributions page but it's just a list where you can't tell if there are new posts or not.

#14 Edited by nutcrackr (12147 posts) -

Is this the secret PC and Mac Games forum?

#15 Edited by FelipeInside (24621 posts) -

Is this the secret PC and Mac Games forum?

Why yes....yes it is.... welcome back to the CULT !!!

#16 Posted by _SKatEDiRt_ (2528 posts) -

This is complete garbage. Im finding another site to JOIN

#17 Posted by Arthas045 (4860 posts) -

This really cracks me up.... It seems like we have our own forum with this old favorites link......

#18 Edited by bonafidetk (3812 posts) -

A secret forum for people who used a bookmark.

#19 Posted by Ser_Charles (51 posts) -

Where are the previous threads? They will be transferred to here later or we start a whole new beginning?:)

#20 Posted by Ser_Charles (51 posts) -