Wrong resolution in game cant see to change settings.

This topic is locked from further discussion.

#1 Posted by Pitbull14218 (222 posts) -
My pc is hooked to my HDTV and it supports 1360 x 768 I accidently picked the wrong resolution in Counter strike Source, so now when i open up source my monitor says no input and i cant see the game so i cant change it back. is there away to force it to be a resolution without opening it? thanks. i was looking forward to playing it in widescreen but it didnt have any resolution for it. :( please help.
#2 Posted by Pitbull14218 (222 posts) -
is there something i have to download that might help? or commands? thanks sorry i really want to fix this soon.
#3 Posted by 205047247090237824329930235794 (741 posts) -
  • Right-click CS:S in Steam
  • Click Properties
  • On the General tab, click the "Set launch options" button
  • Type "-width 1366 -height 768" (without quotes)
  • Start the game and be sure you can see it
  • When you're done playing, remove the above line from Launch Options (no longer needed)
#4 Posted by Pitbull14218 (222 posts) -
i did that and for some reason the game opened in 640 by 480 . I dont know why it did it. i will keep messing with it, is there another way? thanks.
#5 Posted by 205047247090237824329930235794 (741 posts) -
If the game loads and is *visible* at 640x480, go into the graphics settings and see if you are allowed to change the aspect ratio to 16:9. If you are, do that and then change to the widescreen resolution your TV supports. If you aren't, then something isn't working properly because the game thinks your TV isn't a widescreen display. Is your desktop currently set to the monitor's native widescreen resolution [1366x768]?
#6 Posted by Pitbull14218 (222 posts) -
Everytime i open counter strike the Game changes my Tv's resolution. Then when i close it, the Desktop resolution goes back to 1024x768. Strange. Do you think its because my old monitor max res, was 1024x768? When i restart the computer it also makes it start everytime at that res. I allows have to switch it to 1360x768. I use ATi's Catalyst to change the desktop to that res. because it only showed 1024x768 if i right click the desktop and change it in the properties. Do i need a driver for my TV? or should i uninstall the old monitors drivers? i dont know if it has them but it came with a cd when i bought the computer from bestbuy a year ago. I tried the program Game resolution switcher but it did the same the game would start in 640x480, even though it tries to set it to what the desktop is at. which is1360x768. i was hoping for widescreen gaming. think it might be the drivers? thank for the help so far.
#7 Posted by 205047247090237824329930235794 (741 posts) -
I doubt it's the drivers. It sounds like Windows is limiting the resolution to 1024 x 768. The fault could lie with Windows or it could lie with the TV itself. If you aren't able to choose the native resolution with the Windows display settings, then that may be why games won't go to the native res, either. I would try going into the monitor properties in Windows and unchecking "Hide modes that this monitor cannot display" to see if that helps.
#8 Posted by Pitbull14218 (222 posts) -
sorry been awhile, i decided to try to fix it again. did the thing in the properties so i can switch the resolution to any of them. it still wont show it in the game, is there anything else. thanks so much so far.
#9 Posted by Pitbull14218 (222 posts) -
Is there other codes i can put in the launch options i want to play it in widescreen but it wont!!! Maybe can i force the aspect Ratio?
#10 Posted by 205047247090237824329930235794 (741 posts) -
The game will detect aspect ratio settings on startup. To my knowledge there isn't a cvar you can put into Launch Options to force it. In short, if Windows isn't getting your aspect ratio / resolution right, then the game won't be able to, either.
#11 Posted by gs_one (54 posts) -
Have you tried modifying the CS .ini/.cfg file with Notepad? (i forgot which line to modify, it's been a while) Browse the CS directory with Windows Explorer and modify the resolution line. (backup the file beforehand, btw)