Sims 3 Won't Start

This topic is locked from further discussion.

#1 Posted by WolfManMike69 (9 posts) -

My computer is custom built with the following Hardware: AMD Phenom II X2 550 Processor, 3.10 GHz, 1.00 GB RAM, with a 1000 GB Harddrive and NVIDIA 9800 GT Graphics card. P.S. the case for it has six fans. Also, all drivers are installed and updated, I use Realtek Sound, Internet is sufficient. Plus my old computer would run this game so I am going to ask why my new computer won't run something an old clunker would run? When I put the CD in it acts like It'll start the game but a black screen appears then vanishes. The game never starts and leaves me on the desktop with a stupid look on my face wondering why everytime I get something good for my computer it just blows up in my face. Should I have stop caring I would have just left the computer buisness alltogether. So I am asking for help.

#2 Posted by thespywholied (3354 posts) -

Are you fully patched?

Have you tried reinstalling??

#3 Posted by WolfManMike69 (9 posts) -

I've done both. But nothing happens.

#4 Posted by WolfManMike69 (9 posts) -

Also patches wouldn't cause that.

#5 Posted by thespywholied (3354 posts) -

Might want to contact them with that. :?

#6 Posted by quijeros (1728 posts) -

You're lacking in the RAM. Have you had any problems running any other applications or games? These days, 1GB memory is barely enough to run Windows.

#7 Posted by thespywholied (3354 posts) -

You're lacking in the RAM. Have you had any problems running any other applications or games? These days, 1GB memory is barely enough to run Windows.

quijeros

Bingo. A 4 GB would do well.

#8 Posted by yax93 (47 posts) -
useful for me, thanks
#9 Posted by WolfManMike69 (9 posts) -

If your certain on that then I will try getting more RAM, ty.