Running Steam games and picking your GPU

#1 Posted by Oemenia (10221 posts) -

Im on a laptop so my system has an Intel GPU on the CPU as well as a dedicated NVIDIA GPU. Unfortunately on Steam with older games the only seem the detect the Intel. Im trying to play Morrowind which works perfectly in Window mode but fails to start in Fullscreen.

Any ideas?

#2 Posted by PredatorRules (7255 posts) -

I don't think it has anything to do with GPU or CPU, try running in compatibility mode, set it on Windows XP

#3 Posted by Coseniath (451 posts) -

Hello.

This is a comon problem with Nvidia Optimus.

The best work around for now is to go into your NVIDIA Control Panel, go to Manage 3D settings. In the global setting tab change the Preferred graphics processor, it will more than likely be set to auto select, change it to High-performance NVIDIA processor. Or choose the game you want to play and select the High performance Nvidia processor.

#4 Posted by Oemenia (10221 posts) -

I have set my NVIDIA GPU as default, and in the case that doesn't happen then I do it manually from the .exe. Unfortunately on Steam this is a problem since you cant launch directly from it.