Metro: Last light is pissing me off.

#1 Posted by niko_a99 (7 posts) -

I'm trying to play last light, but its unbelievably laggy for no apparent reason. PhysX is off, I tried running it on the lowest settings and it still lagged. My specs are:

Nvidia GTX 780m SLI

OC'd intel core i7 3920 xm

16gig ram

Windows 7

I tried dedicating the second graphics card to PhysX and still nothing...

help? advice? anythings welcome...

#2 Posted by PredatorRules (8495 posts) -

update drivers

#3 Posted by niko_a99 (7 posts) -

Geforce experience says everythings up to date....

#4 Posted by 04dcarraher (20090 posts) -

Disable the SLI if its still laggy its something else ,are you using an 5400rpm hdd?

#6 Posted by vfibsux (4217 posts) -

@niko_a99 said:

I'm trying to play last light, but its unbelievably laggy for no apparent reason. PhysX is off, I tried running it on the lowest settings and it still lagged. My specs are:

Nvidia GTX 780m SLI

OC'd intel core i7 3920 xm

16gig ram

Windows 7

I tried dedicating the second graphics card to PhysX and still nothing...

help? advice? anythings welcome...

If you can't even run on the lowest settings with lag something is certainly wrong. Have you tried overriding the game settings with Nvidia control panel? Try this fix someone posted, had a similar setup to you....

1. Run MetroLL, go into settings and disable vsync in the in-game video settings. Save, quit game.

2. Under Nvidia Control Panel, I went to the game specific settings and set vsync to "use the 3D application setting" but I left triple buffering on.

3. Then go to rivatuner and set your framerate-limiter to 60.

4. Run game. You will notice the stuttering will be gone, but you'll have massive screen tearing. Go back into the game's in-game options, go to video, then set vsync to "on". (Note: in rivatuner it says to disable vysnc when you have the framerate limiter on so it will function properly, but I've had no problems having both vsync turned on in-game with the framerate limiter set to 60).

This is what I did, and the game runs as smooth as anything I've ever played. I have SSAA set to 2x, since that keeps my temps below 70c. If I set it to 4x, my FPS drop below 60 and my temps skyrocket. Even setting SSAA to "off" is ok because the game still looks am

#7 Posted by AdamPA1006 (6420 posts) -

I know you have Nvidia but try turning off Physx

#8 Posted by kraken2109 (13160 posts) -

Does your laptop also have integrated graphics? Sounds like it isn't switching over in this game.

#9 Posted by vfibsux (4217 posts) -

@AdamPA1006 said:

I know you have Nvidia but try turning off Physx

Read his post again.....

#11 Posted by AdamPA1006 (6420 posts) -

@vfibsux said:

@AdamPA1006 said:

I know you have Nvidia but try turning off Physx

Read his post again.....

My bad, just skimmed it. I would try a uninstall and reinstall of drivers.

#12 Posted by Blutfahne (275 posts) -

Game ran super buttery for me. Something has got to be wrong. Defrag, run virus scan, run CCleaner, reset cmos.

#13 Edited by Behardy24 (4758 posts) -

try deleting your local files and reinstall your game. That's what I do.

#14 Posted by insane_metalist (6498 posts) -

SLI here and it runs beautifully.
Try disabling SLI and see what happens.

#15 Posted by IMAHAPYHIPPO (2706 posts) -

Sounds like you might have something else clogging up your computer. The most common cause of lag in high-end computers are viruses from too much porn. ;)

#16 Posted by geniobastardo (1294 posts) -

@IMAHAPYHIPPO said:

Sounds like you might have something else clogging up your computer. The most common cause of lag in high-end computers are viruses from too much porn. ;)

The truth.

#17 Posted by IMAHAPYHIPPO (2706 posts) -

@geniobastardo said:

@IMAHAPYHIPPO said:

Sounds like you might have something else clogging up your computer. The most common cause of lag in high-end computers are viruses from too much porn. ;)

The truth.

The solution to this problem -- a system reboot and a girlfriend.

#18 Posted by geniobastardo (1294 posts) -

@IMAHAPYHIPPO said:

@geniobastardo said:

@IMAHAPYHIPPO said:

Sounds like you might have something else clogging up your computer. The most common cause of lag in high-end computers are viruses from too much porn. ;)

The truth.

The solution to this problem -- a system reboot and a girlfriend.

and a life.

#19 Posted by kungfool69 (2581 posts) -

make sure the power settings of the laptop are set to "performance", make sure u are on ur power charger too. DEFINITELY NEED COOLING OF SOME SORT.

#20 Edited by Cyberdot (3539 posts) -

It's a laptop, man. Problem identified.

#21 Edited by Ribstaylor1 (1078 posts) -

Make sure you have your laptop in a cool place when playing as a duel 780m setup will blast the heat causing issues. Also make sure your not using your integrated graphics for power savings over your 780m's. Try going into your Nvidia control panel and changing some of the settings in there read up on the stuff in it though don't just change stuff blindly. Also are you using super sampling or uber sampling or resolution scaling? If so don't as it might be the issue even though you have good cards. Also duel GPU's can have problems in certain games, I'm not usre if this is one of those but if all else fails turn a GPU off and try it with 1. It might fix your issue.

Edit: Also before entering the game exit all unessential programs. Then enter the task manager and exit everything that is running that doesn't need to be for your system to run. Laptops tend to come packed with bloatware, that starts up on start up and slows you down. It's all ways best to have it all off besides the bare essential.

#22 Posted by wis3boi (31716 posts) -

@Cyberdot said:

It's a laptop, man. Problem identified.

No. When I game on the go, I can play last light on a 650m no problem. TC needs to turn sli off or clean out the system of other garbage software

#23 Posted by jun_aka_pekto (16827 posts) -

Are you playing with the laptop plugged into AC power or using the battery?