Java Strange Crash.

This topic is locked from further discussion.

#1 Posted by fearhome21 (340 posts) -

Happens to me when im playing minecraft, happens strange times but now minecraft doesnt even opens when i run it.. hmm what is the problem there? i have it with a texture pack 64x64 and far distance


#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000005c182808, pid=7488, tid=7452
#
# JRE version: 7.0_09-b05
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.5-b02 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# V [jvm.dll+0x352808]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# If you would like to submit a bug report, please visit:
# http://bugreport.sun.com/bugreport/crash.jsp
#

--------------- T H R E A D ---------------

Current thread (0x0000000002167000): GCTaskThread [stack: 0x0000000005fe0000,0x00000000060e0000] [id=7452]

siginfo: ExceptionCode=0xc0000005, reading address 0x00000000000000d8

Registers:
RAX=0x0000000000000000, RBX=0x00000000056b1401, RCX=0x000000077ae00460, RDX=0x000000000be80a10
RSP=0x00000000060dfb60, RBP=0x00000000056b1401, RSI=0x0000000789080030, RDI=0x000000078907e7e0
R8 =0x000000078907e7e0, R9 =0x0000000000000011, R10=0x0000000005a70000, R11=0x0000000001e70000
R12=0x00000000056b13ae, R13=0x000000000be80a10, R14=0x000000000215f010, R15=0x000000000000000c
RIP=0x000000005c182808, EFLAGS=0x0000000000010207

Top of Stack: (sp=0x00000000060dfb60)
0x00000000060dfb60: 00000000056b1401 00000000056b1401
0x00000000060dfb70: 0000000789080030 0000000789070081
0x00000000060dfb80: 00000000056b1000 00000000056b8de9
0x00000000060dfb90: 0000000000000400 0000000000000380
0x00000000060dfba0: 000000000220bbe0 00000000021633c0
0x00000000060dfbb0: 000000005c387d18 0000000000000000
0x00000000060dfbc0: 0000000000000000 0000000002170f80
0x00000000060dfbd0: 00000000021676d0 00000000021676c0
0x00000000060dfbe0: 000000000be80a10 000000005c195052
0x00000000060dfbf0: 00000000056b1380 000000000215f1d0
0x00000000060dfc00: 0000000789080030 0000000789fbd1b0
0x00000000060dfc10: 000000000be80a10 0000000000000007
0x00000000060dfc20: 0000000000000008 0000000000000000
0x00000000060dfc30: 0000000002170f80 000000005c18418e
0x00000000060dfc40: 0000000002167000 0000000000000000
0x00000000060dfc50: 0000000000000000 0000000000000000

Instructions: (pc=0x000000005c182808)
0x000000005c1827e8: 24 7d 30 00 eb 04 48 8b 47 08 81 78 18 00 00 00
0x000000005c1827f8: c0 48 8d 48 10 73 0f 48 8b 01 4c 8b c7 49 8b d5
0x000000005c182808: ff 90 d8 00 00 00 80 3d d3 94 35 00 00 74 15 8b
0x000000005c182818: 47 08 8b 0d f8 7c 30 00 48 d3 e0 48 03 05 e6 7c


Register to memory mapping:

RAX=0x0000000000000000 is an unknown value
RBX=0x00000000056b1401 is an unknown value
RCX=0x000000077ae00460 is an oop
{type array class}
- klass: {other class}
RDX=0x000000000be80a10 is an unknown value
RSP=0x00000000060dfb60 is an unknown value
RBP=0x00000000056b1401 is an unknown value
RSI=0x0000000789080030 is an oop
[Z
- klass: {type array bool}
- length: 2
RDI=
[error occurred during error reporting (printing register info), id 0xc0000005]

Stack: [0x0000000005fe0000,0x00000000060e0000], sp=0x00000000060dfb60, free space=1022k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V [jvm.dll+0x352808]

the error is pretty big gamespot doesnt let me to write longer than 20.000 characters..

#2 Posted by darksusperia (6943 posts) -
update java to latest.
#3 Posted by fearhome21 (340 posts) -

Thank you it worked, um i have INTEL why does it says amd64??

#4 Posted by darksusperia (6943 posts) -
short version: your using the x64 package. longer version: AMD developed the 64 bit instruction extension, so 64 bit packages are commonly referred to as AMD64 and 32 is i386.