'Failed to create D3D Device!' error on Steam games - Nvidia 8800 GTX

This topic is locked from further discussion.

#1 Posted by samedizombie (100 posts) -

I've had Steam running on my PC for over a year now with no problems. After buying Left 4 Dead and playing it for a while I suddenly started getting the 'Failed to create D3D Device!' error. After checking the Steam support page I un-installed my Nvidia beta drivers, (I have an 8800 GTX) and installed the WHQL drivers from Nvidia's website.

All was well until recently the same error appeared. By chance there were new GPU drivers released that day so I installed them only to find the error still there. Now I am unable to play any Steam game, (Portal HL2, etc.) I know there's a few topics around concerning the 'Failed to create D3D Device' and I've tried them all, reinstalling Left 4 dead, reverting to an earlier GPU driver, cleaning the registry, all to no avail.

I've left a report on the Steam Support Page but so far they've not replied.

Short of un-installing Steam itself and starting again I can't think of anything else to try.

I'd really appreciate any help on this before I try Steam un-install.

Thanks in advance.

#2 Posted by saint_ang3r (2 posts) -

try the following link. Seems like it has helped people with the same issue you are having. Good Luck

http://forum.notebookreview.com/showthread.php?t=322991