Diablo 2 weird colors..

This topic is locked from further discussion.

#1 Posted by elite_destroyer (1118 posts) -

I downloaded the demo for diablo 2 cause i want to get it in a few days.. When I play it i get very weird colors in some areas like its only using that 256 color thing or something.. i dunno i cant really explain it good. lol. if anyone has a clue what im talking bout can you help? I really want to get it but if im stuck with this issue I dont think id wanna get it.. oh im on vista 64 bit if thats an issue :p

#2 Posted by pvtdonut54 (8554 posts) -

I own Diablo 2 on Vista 64. Runs perfectly fine.

#3 Posted by elite_destroyer (1118 posts) -

maybey its just the demo then? cause when im playing some the stuff is colored fine.. but somethings have like a rainbow of pixles..

#4 Posted by chikinlad (1167 posts) -

alt-tab it a few times and see if it goes away

#5 Posted by thusaha (14495 posts) -

Try compatibility mode > run in 256 colors.

#6 Posted by elite_destroyer (1118 posts) -
well what i did was start playing.. pause then minimize. wait a few minutes and maximize and it was fine.. but i did get flickering a bit.
#7 Posted by whatisazerg (2371 posts) -

Off topic, sorta..... Diablo 2 is getting another big patch sometime b4 D3 launches.... just FYI.

#8 Posted by Pvt_r3d (7894 posts) -
well what i did was start playing.. pause then minimize. wait a few minutes and maximize and it was fine.. but i did get flickering a bit.elite_destroyer
I have the exact same problem as you while playing the demo. I couldn't really find a solution myself
#9 Posted by Doriphor (1 posts) -
I had the same problem, although on Windows Seven, for both Diablo and Diablo II, so I kept searching and, by chance, I found the solution, it really works on my PC, but it sounds weird : I had to put a solid color as a desktop wallpaper AND (that's the weird part) open the "screen resolution" window and leave it opened... I still don't understand why it works... besides, it only works with that particular window.... Another solution was to change my color depht to 256 colors (that's why I was on the "screen resolution" window anyway) but it's far more annoying to switch the color depth everytime... Anyway, I hope this solves the problem :)
#10 Posted by mouche119 (1 posts) -
Hey dude I got windows 7, had the same problem and your method worked.... kinda weird though... ;)
#11 Posted by -Unreal- (24474 posts) -

Anyone know if its possible to increase the resolution past 800x640?

#12 Posted by DanielDust (15402 posts) -

Anyone know if its possible to increase the resolution past 800x640?

-Unreal-
Yeah there is a mod, check on moddb.com or just google Diablo 2 resolution mod. But it's kinda weird, because you see a lot more yet almost nothing, all the objects are way too small.
#13 Posted by denter21 (1283 posts) -
All you have to do to run Diablo 2 properly in Vista 64 (as I do often) is check off the boxes to: - run in compatability mode for XP SP2 - disable visual themes - 256 colours - disable desktop composition - run as administrator The end.
#14 Posted by deborah_bedi (1 posts) -
Windows 7 and Diablo II: Doriphor was right about solid background and open screen resolution window. However, changing resolution to 256 as an alternate solution didn't work for me.
#15 Posted by Yitram (1 posts) -

Yeah I just got the battlechest, and I"m running windows 7 and was having the same issue. Suprisingly this solution DOES work. Now I just need to find a way to make my computer automatically switch my desktop and open that window when i want to play it -_-

#16 Posted by lge777 (2500 posts) -

Ijust downloaded it last weekFor a Windows 7 OS and it works perfect

#17 Posted by ewookie (1 posts) -
i had the same color problem. i ran D2VidTest and used it's recommended setting (Direct3D in my case). everything was fine after that. i didn't need any 'compatibility' settings after that.
#18 Posted by druglord187 (3 posts) -
Doriphor is right. His solution, although weird, worked for me.
#19 Posted by Hell_BlazerAp (1 posts) -
[QUOTE="Doriphor"]I had the same problem, although on Windows Seven, for both Diablo and Diablo II, so I kept searching and, by chance, I found the solution, it really works on my PC, but it sounds weird : I had to put a solid color as a desktop wallpaper AND (that's the weird part) open the "screen resolution" window and leave it opened... I still don't understand why it works... besides, it only works with that particular window.... Another solution was to change my color depht to 256 colors (that's why I was on the "screen resolution" window anyway) but it's far more annoying to switch the color depth everytime... Anyway, I hope this solves the problem :)

Holy crap!!!!!!!!!!!!! YOU ARE A GOD MY FRIEND! BEEN SEARCHING A SOLUTION AND IT WORKS! HOW U THOUGHT OF THIS I DONT KNOW! TRY THIS!!!!!!!!!!!!!!
#20 Posted by Fusionmix (1656 posts) -

I'll keep that in mind for when I upgrade to win7.

I'm running XP SP3 and Diablo 2 freezes and hardlocks the entire machine randomly. Nothing running in the background, latest patches and video drivers, vsync turned off for opengl. The freezes are completely random. When they first start happening I can alt-tab out and back in to fix them, but eventually the whole machine becomes unresponsive.

Any miracle fix ideas? :|

#21 Posted by truthincliche (1 posts) -
Alternate solution: -right click on desktop -select personalize -select display -select change display settings -select advanced settings -select the "monitor" tab -change colors to high color (16 bit)
#22 Posted by Elann2008 (32953 posts) -

I own Diablo 2 on Vista 64. Runs perfectly fine.

pvtdonut54

Well that doesn't help the TC, does it? :P Anyways. I'm using Windows 7 64-bit. In compatibility, I use Windows XP SP2. Under settings, the only item I have checked is disable desktop composition. Go into Diablo 2 directory or main folder and run the video test or skip it and select 3D, not DirectDraw. This is what "I" use. It could be different for you. But this most likely work for you as well. Note: I am using a multi-res mod as well because I only play SP and it plays great. No color issues at all. Before, I was using Windows 95 and I was getting all those colors. Windows XP SP2 seems to work better for a good number of users.

#23 Posted by andwon (1 posts) -
Just run D2VidTst It comes with Diablo if you install from a disc like I did. You could also probably just find it online and download it. Running D2VidTst (found in Program Files > Diablo II or wherever you installed Diablo 2) totally fixed this rainbow pixel problem for me.
#25 Posted by Rilesman45 (1 posts) -
Right click on your desktop and click personalize, and make sure that "Windows color" isnt set to basic. I changed my background to the default windows 7 and that made my windows color turn to "Sky". That did the trick and now the colors are fixed. Hope that helps
#26 Posted by HumbleServant6 (6 posts) -
I had the same problem as you and I am on Win 7, just ran it in 256 colors and it worked fine. Game's old, after all, no surprise that it's got that kinda issues with those new computer thingies, nowadays.
#27 Posted by Masculus (2800 posts) -

You don't need even to change color properties. Just right click into the desktop and press personalize, it should make it go away.

#28 Posted by ehammer41 (1 posts) -
Just bought a PC running windows 7 loaded Diablo 2 and screen Res was terrible, went to setting and dropped the Res down to 800/600, loaded it back up and alt-tab out once. When you go back in it is still pixelated but once you get to character selection everything is fine. Hope this helps
#29 Posted by Adnon2012 (1 posts) -
I found the solution on someone's video on Youtube. The best way to solve the problem is by finding the folder where you installed the game Diablo II, looking for an application called D2VidTst, and selecting Direct3D when it's done. This will solve the color issue and the load time (if you have load time problems.
#30 Posted by trastamad03 (4852 posts) -
I found the solution on someone's video on Youtube. The best way to solve the problem is by finding the folder where you installed the game Diablo II, looking for an application called D2VidTst, and selecting Direct3D when it's done. This will solve the color issue and the load time (if you have load time problems.Adnon2012
I see someone's favorite class in D2 was Necromancer. Since you know... Thread Necro-ing.
#31 Posted by skitchin1 (1 posts) -
On my windows 7 machine diablo 2 only worked with the solid background and leaving the screen resolution screen open. and my settings at stock. but only works with 2d on video test.
#32 Posted by BrunoBRS (73254 posts) -
lol what's with this thread and lv1's reviving it.
#33 Posted by rronqe (207 posts) -
lol what's with this thread and lv1's reviving it.BrunoBRS
Yeah, if you look at post dates, this thread has been revived many times. I guess a google search leads to this thread?
#35 Posted by Starshine_M2A2 (4057 posts) -

Maybe the demo or your computer. Sometimes games get too old for certain specs. Worms Armageddon doesn't run at all on my current PC.

#36 Posted by PetJel (3722 posts) -

Someone shoot the thread in the head so it will stay dead D: