Can't connect to ARMA 2 online servers???

This topic is locked from further discussion.

#1 Posted by RVD92 (122 posts) -

Help!

#2 Posted by KHAndAnime (13450 posts) -
What's your issue specifically?
#3 Posted by RVD92 (122 posts) -

When I try to connect to a server it will gather the things and boot me back to the server list.

#4 Posted by KHAndAnime (13450 posts) -
No error messages whatsoever? Are you fully updated? Are you using a valid ArmA 2 copy? Are you using any mods?
#5 Posted by RVD92 (122 posts) -

The only mod I have is dayZ and I do have a legit copy and it is patch 1.60.

#6 Posted by KHAndAnime (13450 posts) -

Are you trying to play Day Z? If so...

1) Have you run ArmA 2: Combined Operations before?

2) Have you tried using Six Launcher or the Day Z Install Tool?

3) Is ArmA 2 completely patched? Operation Arrowhead and ArmA II both require separate updates.

#7 Posted by jer_1 (7451 posts) -
Does it display any kinds of errors before it returns to the servers list?
#8 Posted by RVD92 (122 posts) -
Yes to all.
#9 Posted by RVD92 (122 posts) -
No sir.
#10 Posted by KHAndAnime (13450 posts) -
Do you have a friend? It's possible that one of your game files have become corrupted. If you have a friend sit in a server and watch you connect - they'll be able to spot an error message that you can't see. Or you may just have to reinstall (sorry to say).
#11 Posted by RVD92 (122 posts) -

Ah rats. I'll try a re-install and get back to youtomorrow

#12 Posted by Iantheone (8242 posts) -
Are you runnning 1.6 or 1.7?
#13 Posted by RVD92 (122 posts) -
Do you have a friend? It's possible that one of your game files have become corrupted. If you have a friend sit in a server and watch you connect - they'll be able to spot an error message that you can't see. Or you may just have to reinstall (sorry to say).KHAndAnime
Okay sir after a fresh install I can't even get past the "Waiting for host" screen :/
#14 Posted by RVD92 (122 posts) -

1.6 sir.

#15 Posted by simardbrad (2355 posts) -

[QUOTE="KHAndAnime"]Do you have a friend? It's possible that one of your game files have become corrupted. If you have a friend sit in a server and watch you connect - they'll be able to spot an error message that you can't see. Or you may just have to reinstall (sorry to say).RVD92
Okay sir after a fresh install I can't even get past the "Waiting for host" screen :/

Try to pick less populated servers and ones that have the lowest possible pings to you.

#16 Posted by Elann2008 (32953 posts) -

I read that if you're trying to join a server and you're missing certain mod files this will happen. As for Day Z mod, make sure you start up Arma 2 and Operation Arrowhead at least once. This is required in order for the games to "sync."

I'm guessing this isn't the steam version? Did you buy Combined Operations or Arma 2 and Operation Arrowhead separately? Because steam versions barely run into issues.

#17 Posted by RVD92 (122 posts) -

I read that if you're trying to join a server and you're missing certain mod files this will happen. As for Day Z mod, make sure you start up Arma 2 and Operation Arrowhead at least once. This is required in order for the games to "sync."

I'm guessing this isn't the steam version? Did you buy Combined Operations or Arma 2 and Operation Arrowhead separately? Because steam versions barely run into issues.

Elann2008
It is the steam version sir.
#18 Posted by Elann2008 (32953 posts) -

[QUOTE="Elann2008"]

I read that if you're trying to join a server and you're missing certain mod files this will happen. As for Day Z mod, make sure you start up Arma 2 and Operation Arrowhead at least once. This is required in order for the games to "sync."

I'm guessing this isn't the steam version? Did you buy Combined Operations or Arma 2 and Operation Arrowhead separately? Because steam versions barely run into issues.

RVD92

It is the steam version sir.

Honestly, I'm a bit surprised. It only takes like 2-3 minutes to setup Day Z mod, granted you already downloaded the mod itself. Maybe this VIDEO will help you, and/or this step by step intructions.

#19 Posted by with_teeth26 (6058 posts) -

I installed Arma 2/Dayz for the first time yesterday and it works...mostly. After I die, or leave a server or joing a different server, I cant get into any game until I restart Arma 2: Combined Operations.

Right as it loads the map, it says "retrying to authenticate server" and just sits there. I can see people's chat but I cant actually load in until I restart the game.

can you get into non day-z servers? try punching your router.