Call of Duty 4 - NO SERVERS

This topic is locked from further discussion.

#1 Posted by Altec103 (14 posts) -

I've been playing CoD4 online for about 2 months now with no problems at all. Well a freind on mine tells me to update a patch so I can play on the new levels.

I install 1.6 and then 1.7 patchs, but when I go to join a server, none of them are avaible.

I keep on clicking refresh, but no servers show up. Period. It connects to the master server too, just no servers show up.

Any ideas on how to fix this?

#2 Posted by Altec103 (14 posts) -
Can anyone help?
#3 Posted by dgsag (6760 posts) -
Reinstall the game, there are 20000 servers up.
#4 Posted by Kuyt19 (856 posts) -
Version conflict i think. But then, maybe not.
#5 Posted by Jinroh_basic (6413 posts) -

this is actually quite a common problem experienced by players after updating their game. as far as i know, nobody exactly knows why, as apparently the majority have no problem with the patches. but of coz, that doesn't mean the problems don't exist.

mostly people would just advise you to reinstall the game and patch it only the version you previously played on. but yea, like i say, nobody exactly knows what's wrong and how to deal with this.

#6 Posted by Altec103 (14 posts) -
If I reinstall, will I loose my profile?
#7 Posted by name294 (1463 posts) -

If I reinstall, will I loose my profile?Altec103

I don't think so, whenever you uninstall a game, they should give you an option to erase profile and saved games. Just click "no".

#8 Posted by Altec103 (14 posts) -
How do you reinstall a program? And does any else have any ideas to fixing my intial problem?
#9 Posted by DanielDust (15402 posts) -
If you have an antivirus see if you have exceptions for it otherwise it will block CoD and it will not show any server. To uninstall the easiest way is to insert the disc and press uninstall.
#10 Posted by Altec103 (14 posts) -
I know that nothing is blocking it because I played before I installed the patches.
#11 Posted by DanielDust (15402 posts) -
If you do have an antivirus you will have to set an exception for it for every patch.
#12 Posted by k_ozz (1088 posts) -
Its better u don uninstall the game.. Cos u will loose ur multiplayer stats. Before u uninstall u will be asked whether or not ur saved files should be deleted.. Well thats only for the single player.. U will loose all ur multiplayer progress.. And u must start from scratch.. But there is a method how u can uninstall the game without losing ur multiplayer progress.. Just search the method on google..
#13 Posted by k_ozz (1088 posts) -
And u r not getting any servers cos no servers are patched to 1.7... Just wait for a week or so..
#14 Posted by soren91 (4 posts) -

Wow dude nobody knows how to fix it? makes me a genious or what... its easy u just download Utorrent and then u go to Speedguide and type : 28960 when u have done this u should be able to play again...

feel free to share this with others since theres 100 forums out there with the same problem..

#15 Posted by OneNeo1 (390 posts) -

ok, let's pretend we are all complete 'tards here; could you please explain what a torrent client has to do with game servers?

I would really like to know.

#16 Posted by soren91 (4 posts) -

maybe he somehow closed the ports for cod 4 - if u use utorrent it will allow / open the ports again and you should be able to see the list again

there u go more you wanna know?

#17 Posted by soren91 (4 posts) -

ok, let's pretend we are all complete 'tards here; could you please explain what a torrent client has to do with game servers?

I would really like to know.

OneNeo1
O why dont u answer smart ass ;)
#18 Posted by OneNeo1 (390 posts) -

NO soren91, I was NOT trying to be a smart a$$, I was serious, I have never heard of someone using a torrent client to open ports for a game before. A clever little pseudo-hack.

It should be really easy to do within your firewall program, all you need to know is which ports the game needs open, heck some of the firewall programs have a gui interface that allow you to set levels of security on a per program basis.

But it is interesting that the uTorrent trick actually will work, I always thought that the ports only remained open as long as the client was running, if you shut it down the ports close again. And IF you have the client running, and have an older machine, or an internet connection that isn't so good, well the torrent client will just make your system chug.

Seriously, I do appreciate the reply soren91 !!!

#19 Posted by zomglolcats (4335 posts) -

maybe he somehow closed the ports for cod 4 - if u use utorrent it will allow / open the ports again and you should be able to see the list again

there u go more you wanna know?

soren91

Orrr.... you could just open up the interface for your router and open ports that way. No need for uTorrent quite honestly.

#20 Posted by DeadDuck84 (1 posts) -

ok i have a problem... i bought the game and have downloaded and installed both the 1.6 and 1.7 patches. played the game for atleast 3 weeks with not one problem... 2 days ago it just started not refreshing the server list??? every time i refresh it does nothing. has anybody ran into this problem? i even uninstalled the game, ran disc cleanup, everything i could think of... I need help!

#21 Posted by dumbummy (4 posts) -
i have not play a single cod4 game casue no servers come up and i have downloaded patchs 1.4 1.6 and .17 is that good but .1.4 was the last one i down loaded
#22 Posted by kozzy1234 (35153 posts) -

http://www.gametracker.com/search/cod4/US/

Go to this site... it lists all the cod4 games that are being played in each country. I use this site for COD WAW as i cant join games in teh browser.

Just enter the browser (its the ~ button on WAW) and then type in "/connect" and then the IP address of the game you want. Its really easy.

Also try uninstalling COD4 and reinstalling it. Then make sure to install the patchs in the right order. Also check that website i mentioned above for up to the minute server IP address's for COD4 games.

#23 Posted by Malphal (529 posts) -
you were able to play before the patches and now you can't so it is the patches. Right? They may be blocked by your anti whatever software. No biggy. Just fix it.
#24 Posted by khassineboy (13 posts) -
hey man, did you get your cod 4 fixed?? cause i'm having the same problem...
#25 Posted by freesafety13 (823 posts) -
hey man, did you get your cod 4 fixed?? cause i'm having the same problem...khassineboy
I'm going to assume you didn't realize this thread is 2 years old.
#26 Posted by khassineboy (13 posts) -
i know its two years old, but im having the same problem lol
#27 Posted by fredgroon (1 posts) -
Hi I also got this problem -.- can someone who have fixed please reply and inform of what they did? please. would be appreciated
#28 Posted by gutlessvader (1 posts) -
I'm getting the same issue.
#29 Posted by Sharpy63 (1 posts) -
I think your ports are behind the router or something? I don't really know, I'm confused because it isn't working for me either, I need assistance please, and I know this is a 2 year old thread.
#30 Posted by wis3boi (31103 posts) -

you new users need to quit resurrecting 3-4year old threads on this board....

#31 Posted by biggest_loser (24029 posts) -
Reinstall - I should get back to playing that myself. Each one since 4 has been a little weaker.
#32 Posted by tbag99 (2 posts) -
first off, patch the game to 1.7 secondly, punkbuster needs to be installed. navigate to: applications > call of duty 4 > technical support, and run pbsetup.run might need to update punkbuster but that should do it.... pc
#33 Posted by tbag99 (2 posts) -
if you cant update get new pb here : http://www.evenbalance.com/index.php?page=dl-cod4.php
#34 Posted by joshmurder (1 posts) -

this is what you have to do you have to do is to download it agiain i know you will be sad beccause you will lost all of your saved rank but it haved to do it

#35 Posted by MEOWWW123 (867 posts) -
zomg thread necro. how ever im having this exact problem as of today... so... convenient much?
#36 Posted by benleg123 (1 posts) -
i have the same problem, but when i press the ,"~" button, the box to type the IP adress does not come up how do i fix this?