Bioshock won't launch... D:

This topic is locked from further discussion.

#1 Posted by CheatIsNotDead (681 posts) -

"Bioshock.exe has encountered a problem and needs to close. We are sorry for the inconvenience."

This is what I'm getting when I try to play Bioshock. I downloaded it on steam, tried to play it today (it's been playing fine before), and I'm getting an error that it need to close before it has even launched.

Does anyone know what I can do to fix this? I need my plasmid fix BAD.

Thank you in advance. If you need more info I'll try to help.

~TCIND

#2 Posted by CheatIsNotDead (681 posts) -

I assure you I am extremely sorry for this. I really don't know what to do and do need some help.

Is it possible to un-install and re-install Bioshock without

1: Losing my save Data

2: Having to re-pay for it

I'm pretty sure I can do #2, but If I can't that would be a cataclysmic mistake.

And with that second question... *sigh*

Bump.

~TCIND

#3 Posted by CheatIsNotDead (681 posts) -

I went and 'verified the integrity of game cache', and Defragmented the cache.

Now I get a breif 1 second flash of a loading screen before getting a new error:


Bioshock.exe –Application Error

The Instruction at "0x10c98aa7" referenced memorty at "0x00000000". The Memory could not be 'read'.

Click on OK to terminate the program

Click on CANCEL to debug the program

I'm really really sorry to be re-reposting, but this is the only forum I belong to. Can no one help?

~TCIND

#4 Posted by rolo107 (5470 posts) -
I have the EXACT same problem, except I get to the first part where he's smoking and then during the loading screen I get those errors. It's annoying. I've looked around everywhere, I can't find a fix. I've tried literally everything. Sorry mate.
#5 Posted by Gruff-182 (62 posts) -

Exact same problem. Justbought the game so my drivers can't be out of date.

I get the Bioshock splash screen, then nothing.

#6 Posted by clembo1990 (9976 posts) -
Post the O/S you are using.
#7 Posted by clembo1990 (9976 posts) -
Do what the first reply says: http://forums.2kgames.com/forums/showthread.php?s=36a6562170153ec0cb35c8d224da3284&t=14220&page=2 If you have a laptop, I'm sorry but that might not work out: http://forums.2kgames.com/forums/showthread.php?t=13188
#8 Posted by Chris_53 (5103 posts) -
Just reinstall the game, that should work shouldnt it?
#9 Posted by Drmario1999 (2 posts) -
My bioshock doesn't work!!!!! I bought my bioshock at a thrift store. I was so happy i install it lunch it it says:Bioshock.exe has encountered a problem and needs to close. We are sorry for the inconvenience.I meet the recommend&minimum requirements.Please help me I want to play bioshock SO BAD!!!!!!!!!!!!!!!!!!
#10 Posted by Drmario1999 (2 posts) -
I forgot to add that my computer is windows xp
#11 Posted by Boomboomer (1 posts) -
Mine won't work either, it won't even start the application, it just hangs when the bioshock launcher is started. I meet the minimium requirements, have uninstalled and re-installed to no avail. HELP!!!