any reason why my Wii shop won't connect

This topic is locked from further discussion.

#1 Posted by fiercedeity901 (6291 posts) -
ok i can connect to everything from the forecast channel, everybody votes, news, and internet channel.....but for some reason not the wii shop channel...it goes to the screen that says "connecting. please wait..." and i let it do it's thing for like 30 minutes on several occasions and once for and hour and it just never fully connects and FYI i'm connected to my two wire through wireless communication and i have all three bars filled, so that shouldn't be the problem because when i first got my Wii (november) it connected to it fast and without fail....now over the past two months it just doesn't work any reason you guys know of why it won't connect???
#2 Posted by fiercedeity901 (6291 posts) -
does anyone know?
#3 Posted by cobrax80 (4658 posts) -
Maybe the servers are temporarily down, keep trying to connect later. If not then maybe something is wrong with your connection or Wii.
#4 Posted by fiercedeity901 (6291 posts) -
Maybe the servers are temporarily down, keep trying to connect later. If not then maybe something is wrong with your connection or Wii.cobrax80
i don't think they've been down for two months, lol....and it can't be the connection or else i wouldn't be able to get on the other channles...so idk what it could be
#5 Posted by gromit007 (3024 posts) -
Were you ever able to go to the Shop Channel. If so, have you changed your router recently. The router may be blocking the port the channel uses, or the firewall is kicking in for some reason.
#6 Posted by CyWii (1 posts) -
Mine keeps saying that it's not available in my country. I checked the country setting and I have it set as the US.
#7 Posted by huygir (14 posts) -

I am having the exact same problem. I did make some changes to my firewall recently, so I'm thinking that could be it... may the Wii store uses SSH ports or web server ports to talk back.

I'll only know for sure when I remove those rules - which I am about to try.

If it works, I will let you know.

#8 Posted by huygir (14 posts) -

That was it. I turned off port forwarding rules for HTTP, HTTPS and SSH and I now connect quickly to the Wii store.

Not sure which rule was causing the problem, but I'm betting SSH since the others are more likely to exist on many personal firewalls... but you should experiment if you need to know for sure :-)

Cheers.