Help! Game will NOT load. Recall?

This topic is locked from further discussion.

#1 Posted by ebooks_basic (22 posts) -

I have an Age of Empires (The Age of Kings) game that will no longer load. I played it for about an hour and saved it. I went to play it today and the two DS screens just go black after selecting the game on the touchscreen. I have tried different buttons, but nothing seems to work. This is my second copy of the game I got (returned the first one). Now I am thinking it is either the game's design or the DS design that is causing a problem. What are the odds of getting two defective games back-to-back? Does anybody know if the games have been recalled?

Anybody else have this problem? Is it OE? LOL!

Any help would be greatly appreciated.

Thanks.

#2 Posted by StarFoxEXR (689 posts) -
The problem probably resides within your DS unfortunately. Have you tried other games and got the same results, or is that your only game? Both copies being jacked is a bit of a coincedence.
#3 Posted by SonicBoom344 (685 posts) -

Your DS is fine. Age of Empires: Age of Kings has a glitch like that. It's something to do with having usernames under 3 letters. Also Save & Quit glitches the game. I've had it happen to me once.

#4 Posted by ebooks_basic (22 posts) -

Ok. Thanks.

So how did you get your version up and running again?

#5 Posted by SonicBoom344 (685 posts) -
I had to exchange mine, actually. -_-