Any PC users here that can report?

#1 Posted by Barlerer (2 posts) -

Hi there, any PC gamers that can say if the game has any problems like battlefield 4? Crahses... FPS Drops... stuttering...

#2 Edited by EsteemSVX (7 posts) -

Not crashes, but I do get a bit of frame drop going over one of the bridges and one of the forested areas. I'm using dual 7950's so I'm going to write it off as "lack of xfire optimization" at the moment. BF4 (maxed) gives me little trouble at all. I played till 4am PST and everything seemed ok. Few latency bumps, but who knows who I was playing against at that hour. There are only a few things that bug me so far.

1. Six player sessions seems reaaaally small for this kind of game, albeit fun being the only cop.

2. Host migration mid event seems to kill your speed points built up.

3. Not really sure how the matchmaking is setup, but it seems there needs to be balancing. One moment I dominate racers with little effort, next session I can't catch racers while driving the Aventador on full burn.

Other than that it's really fun, just wish the servers were more populated.

#3 Posted by Semantia (185 posts) -

@EsteemSVX: What drivers are you using? I'm current running 2x7850 and I can't even get the game to launch in fullscreen. Get this weird glitching.

#4 Posted by Barlerer (2 posts) -

Not crashes, but I do get a bit of frame drop going over one of the bridges and one of the forested areas. I'm using dual 7950's so I'm going to write it off as "lack of xfire optimization" at the moment. BF4 (maxed) gives me little trouble at all. I played till 4am PST and everything seemed ok. Few latency bumps, but who knows who I was playing against at that hour. There are only a few things that bug me so far.

1. Six player sessions seems reaaaally small for this kind of game, albeit fun being the only cop.

2. Host migration mid event seems to kill your speed points built up.

3. Not really sure how the matchmaking is setup, but it seems there needs to be balancing. One moment I dominate racers with little effort, next session I can't catch racers while driving the Aventador on full burn.

Other than that it's really fun, just wish the servers were more populated.

Thank you very much for this.

#5 Posted by Ozajash (6 posts) -

Game doesn't crashes but it slows down every 3-4 seconds.Game speeds(normal) in menus and videos but it slows down when i start driving car. Playing in video settings didn't gave any improvements. My rigs specs are given below: -

Windows 7 ultimate 32 bit

AMD Phenom II X6 processor 1100T

Geforce GTX 650 2gb ddr3 graphic card

3gb RAM

AOC 60hz monitor LCD

Please give some solution... I wanna play this game..

#6 Edited by EsteemSVX (7 posts) -

@Ozajash I'd check and see if there are any beta drivers available. Also turn off the AA/Post Processsing settings to see if you get any boost. Other than that, the proc is the same one I'm using. I would recommend upgrading to a x64 windows install with 8gb ddr3. However, if video settings/drivers aren't fixing things you may have to wait for a patch.

@Semantia I'm currently using the 13.11 Beta 9.2 x64 drivers. I have xfire enabled for all games and the recent beta drivers don't require a seperate xfire profile download. I'm using the x6 1100T with 16gb of 1600 DDR3 if curious. I also had to set the x64 version as default since it was set to 32bit during the preload settings.

#7 Posted by mtdew332 (298 posts) -

AMD 13.11 beta 9.4 just released which has optimizations for this game listed.

Download Link

Feature Highlights of The AMD Catalyst 13.11 Beta9.4 Driver for Windows

  • Includes all Feature Highlights of The AMD Catalyst 13.11 Beta9.2 Driver
  • May resolve intermittent black screens or display loss observed on some AMD Radeon R9 290X and AMD Radeon R9 290 graphics cards
  • Improves AMD CrossFire scaling in the multi-player portion of Call of Duty®: Ghosts
  • AMD Enduro Technology Profile updates:
  • ​XCOM:​ Enemy Unknown
  • Need for Speed Rivals
#8 Posted by Avenger1324 (16344 posts) -

Core i7 2600K, Nvidia GeForce GTX 670 2GB, 8GB DDR3, Win 7 Ultimate 64-bit

I'm using the latest drivers 331.82 and it all seems to be running smoothly - no noticeable issues with framerates or stuttering.

Host Migration is a bit of a pain - you can be mid race when the host (elsewhere in the gameworld) leaves and it pulls you all back to a loading screen while it selects a new host. Thankfully that hasn't been happening too frequently.

#9 Posted by Khoo1992 (2458 posts) -

I don't have a 360 controller, so I downloaded a x360ce emulator for my F510 Logitech Gamepad. But I don't know the actual mapping with the button assignment with button assigned as button 0,1,2,3,4,5,6 etc...

Anyone know what is the correct mapping?

#10 Posted by Frag_Maniac (2056 posts) -

On the one hand you can say it's fairly well optimized, but given the 30 FPS cap it's not saying much really, as it DOES somewhat limit the overall look and feel of the game.

#11 Posted by Rean2000 (15 posts) -

@Khoo1992 said:

I don't have a 360 controller, so I downloaded a x360ce emulator for my F510 Logitech Gamepad. But I don't know the actual mapping with the button assignment with button assigned as button 0,1,2,3,4,5,6 etc...

Anyone know what is the correct mapping?

i have f310 gamepad, just use logitech gaming software. what i did is, i set the gamepad from X-input to D-input (there is a switch on the back of the gamepad), and mapped gamepad buttons as a keyboard buttons in the software. works wonders.

#12 Posted by imKrishnaMadhav (7 posts) -

Core-i5 2430M ,6gb RAM ,2 gb nvidia gt540m

It crashes few minutes after starting the game with the following error:

"DirectX function "device-->CreateBuffer(&dxDesc,0,&buffer... failed with E_OUTOFMEMORY

('Direct3D could not allocate sufficient memory to complete the call)"

Any solution guys??