Temple Run 2 not working?

This topic is locked from further discussion.

#1 Posted by dan0314 (905 posts) -

I have a pretty old phone (LG Optimus 3D) and when I try to run Temple Run 2 it goes to the loading screen then kicks me back to the Applications screen. I tried un-installing and re-installing but that didn't work. D: By the way, why can't I update my phone? Man I hate Rogers and this phone...

#2 Posted by MonoSilver (1525 posts) -
I had the exact same problem. I downloaded the game, loaded it fine and changed the graphics settings to make it look a bit nicer. I then played it a little bit and exited. Later on when I launched it again, it did the same as you described. I have a Galaxy S which is old but is powerful enough considering it let me play the game before closing it.
#3 Posted by dan0314 (905 posts) -
I had the exact same problem. I downloaded the game, loaded it fine and changed the graphics settings to make it look a bit nicer. I then played it a little bit and exited. Later on when I launched it again, it did the same as you described. I have a Galaxy S which is old but is powerful enough considering it let me play the game before closing it.MonoSilver
Hm... I'm probably going to be upgrading my phone soon, so I guess it doesn't really matter to me right now. Though I have no idea how you could fix it. D:
#4 Posted by Davidwilliam06 (119 posts) -

The game is working absolutely fine on my Galaxy S4.:cool: I even got to try it out on my mates iPhone5 and even there, it is running pretty well.;) I guess you should rate the game on Google Play and leave a comment there for the developers. Also check various forums to see whether others are having the same issue! :!:

#5 Posted by mystic_knight (13801 posts) -

The game is working absolutely fine on my Galaxy S4.:cool: I even got to try it out on my mates iPhone5 and even there, it is running pretty well.;) I guess you should rate the game on Google Play and leave a comment there for the developers. Also check various forums to see whether others are having the same issue! :!:

Davidwilliam06
Hey buddy avoid posting in threads older than 6 months as it is considered disruptive. Feel free to tackle things with a new thread, or in this case just let it go since its too old.