S4 connectivity issues with Kies

This topic is locked from further discussion.

#1 Posted by Aesthete18 (167 posts) -

Anyone here know a fix for this. I've spent the whole night trying to figure it out.

Basically, I install Kies then connect my phone through the USB, it starts to connect but stays on that page. After about 10 seconds or so, a pop-up from my desktop says "a problem occured during hardware installation". In device manager>Portable devices>MTP has an exclamation mark on it.

Things I've done:
- Taken out battery, reinstall Kies, restart PC, put battery in after 1 minute and try again. (forum post from someone who got help through Live Chat Support)
- Install driver from Kies manually through device manager
- Updated driver from online source, also through device manager (Updating with both drivers says "the device is not configured correctly")
- Tried both Lite and normal mode
- Tried troubleshoot connection error on Kies

There are only 3 thing compatible drivers that appear when installing manually in device manager: Digital Still Camera, MTP Device (I'm guessing that's the driver that came with Kies) and Samsung Mobile MTP Device (This is the one I downloaded online). I'm using Windows XP.

 
#2 Posted by danjammer69 (4120 posts) -

I have nothing but problems using Kies, and I am not the only one.

I just avoid using it all all costs. I simply use Windows Explorer to add media or whatever to my Galaxy Tab 2.

The only other thing I would think of using it for is firmware updates. But even that has other methods.

It is just a very buggy program.

Edit: Keep in mind that Kies will also install the MTP driver. So if you installed one beofre hand, it just got overwritten by Kies.

I eventually just uninstalled Kies and the MTP driver and then did a clean MTP install, not installing Kies again.

Good luck.

#3 Posted by adamosmaki (9627 posts) -

Try this. Its for galaxy S3 but the solution is the same for galaxy s4 ( Just dont download the drivers for galaxy s3 from the link i gave you but try and find galaxy S4 Usb drivers. Google search it )

http://forum.xda-developers.com/showthread.php?t=1844400&page=2

Is a problem long time now and usually with a restart it fixes itsself

#4 Posted by Aesthete18 (167 posts) -

I have nothing but problems using Kies, and I am not the only one.

I just avoid using it all all costs. I simply use Windows Explorer to add media or whatever to my Galaxy Tab 2.

The only other thing I would think of using it for is firmware updates. But even that has other methods.

It is just a very buggy program.

Edit: Keep in mind that Kies will also install the MTP driver. So if you installed one beofre hand, it just got overwritten by Kies.

I eventually just uninstalled Kies and the MTP driver and then did a clean MTP install, not installing Kies again.

Good luck.

danjammer69

So I've read, I'll try to look up other ways if adamosmaki's suggestions fails to solve it. Did you try the customer service? I accidently stumbled on the US Live Chat Support. She was helpful but I was redirected to my own country's chat support which turned out to be a joke. I spent 20 minutes answering questions about where I purchased the phone and where I downloaded the Kies. He never even asked me to describe the problem or anything. I eventually called them up and the guy said reinstall Kies and if that doesn't work bring in the phone for service. I'm like are you **** kidding me?! This is obviously not the phone's fault since it's clearly a universal problem.

#5 Posted by danjammer69 (4120 posts) -

[QUOTE="danjammer69"]

I have nothing but problems using Kies, and I am not the only one.

I just avoid using it all all costs. I simply use Windows Explorer to add media or whatever to my Galaxy Tab 2.

The only other thing I would think of using it for is firmware updates. But even that has other methods.

It is just a very buggy program.

Edit: Keep in mind that Kies will also install the MTP driver. So if you installed one beofre hand, it just got overwritten by Kies.

I eventually just uninstalled Kies and the MTP driver and then did a clean MTP install, not installing Kies again.

Good luck.

Aesthete18

So I've read, I'll try to look up other ways if adamosmaki's suggestions fails to solve it. Did you try the customer service? I accidently stumbled on the US Live Chat Support. She was helpful but I was redirected to my own country's chat support which turned out to be a joke. I spent 20 minutes answering questions about where I purchased the phone and where I downloaded the Kies. He never even asked me to describe the problem or anything. I eventually called them up and the guy said reinstall Kies and if that doesn't work bring in the phone for service. I'm like are you **** kidding me?! This is obviously not the phone's fault since it's clearly a universal problem.

Yea that is a joke. Not surprising for most undertrained Customer Service reps though. I would give what adamosmaki said a try. It is a shame that so many resort to NOT using Kies at all. Would be a good program if it worked properly. For a long time I had trouble even getting the MTP service to work properly, Kies or not. I thought it was a Windows 7 or driver issue, but I then installed CyanogenMod 10.1 for my GT2, and it and Kies worked with no problems. This led me to think it had something to do with Samsung's stock ROM. But now I am on stock ROM again and it all works for me. Very strange, since I cannot reproduce what caused the problem, it just resolved itself after uninstall/reinstalling the driver so many damn times. One thing I do know is that whenever I let Window Update install the MTP driver, I get all sorts of issues, where my PC will not even see my tablet and the MTP service crashes. They really need to just reprogram Kies or make something new. Or go back to using the method they used before and which works on my Gingerbread 2.3.6. phone. Plug it in and it is recognized by Windows as a memory card. Problem is the way Samsung made it so they partitoned the internal storage the way they did. Anyway, good luck with this. hope you get it sorted out.
#6 Posted by Aesthete18 (167 posts) -

I was only going to post when I fixed the problem but I've spent many hours on it and can't get Kies to work.

Thanks guys for the help.

If anyone is having this problem and can't get it fixed. I've started using AirDroid, it's very effective and useful. You can transfer anything with it. You can also use SyncMe Wireless to backup your files.