Anybody remember Half-Life? I could use a hand with a seeming bug.

This topic is locked from further discussion.

#1 Posted by TrevorSt (12 posts) -

Yeah, I realize this is a pretty long in the tooth title, but I tend to play older games and just dug this one out again and hit a weird problem which I now remember dogged me before -- think I only got passed it once.  I'm hoping someone has some familiarity with it and can give me a hand.

 

What happens is, I play through the game to the point where Freeman takes the large elevator to the surface. He opens the door, goes inside, pushes the button, and the elevator starts rising making elevator noises.  However, part way up the next scenario loads at which point the sound becomes all helicopter, the elevator stops moving (still down in the shaft I think), the red damage flares start showing, and the heath meter starts dropping.  Very quickly he's dead and yet there's no visible attacker, the elevator door hasn't opened and I'm stuck.  I've tried "Esc"aping the game at that point and then continuing, but it didn't work.  This is the Valve CD box release from way back (Platinum Collection).

 

If anyone can give me a hand, it sure would be appreciated.

#2 Posted by quakke (180 posts) -

I am assuming you mean the scene where the soldiers come and you try to get into the bunker? I guess there really is no other solution than getting a savegame from the internet or loading your earlier save so that maybe hopefully the bug does not exist anymore? I have had something similar with it myself also. Half-Life is a heavily scripted game so try loading that earlier save so that maybe the script will act normaly next time? Also make sure Steam has updated your copy of HL to it's latest state and make sure any files ain't corrupted by checking integrity of the files with Steam.

Edit: Since you said you have a original cd copy of the game (possibly dating back to 98?), you should try inserting your cd-key in Steam for it to recognize your copy of HL. I have a "HALF-LIFE generation" named four disc box (includes HL with all it's expansion packs) which dates back to 2001 and now this package is actually registered in my Steam account. So whenever i install one of these games i actually install them through Steam. Or only use the cd's if i want installation go faster but still, it's Steam which install's it, not Half-Life installer. That way i can have them in their most up to date versions.

#3 Edited by quakke (180 posts) -

I'm pretty sure you have figured this out by now, but just incase you didn't and someone else finds this. Here is what to do.

Because i also wanted to play this original PC bigbox Half-Life1 (without Steam) due to it having the EAX effects and all, i ran into the same problem. It seems that as soon as you get a gun in HL1 and you go to elevator, you get stuck in the elevators floor. Inorder to proceed without doing any patching,cracking or any kinda editing of gamefiles, you need to jump in the elevator. As soon as an elevator starts moving, you start jumping and moving around the elevator. That stops you from getting stuck in the elevator. This is confirmed, because i myself finished the game from start to finish, and all i had to do to get through the elevators, was to keep jumping.