Video Problems and You - AdBlock Awareness

This topic is locked from further discussion.

Posted by DigitalDame (3516 posts) -

Hello GameSpotters,

It has been brought to my attention that some of you (namely those of you who use AdBlocker) have been experiencing some issues with our videos not loading.

This -IS- an AdBlock issue, currently our video player will not work if you are running this software.

NOW! Before you all start panicking and coming up with crazy theories about how this is some way for us to nickle and dime our users let me be PERFECTLY CLEAR when I say that this was NOT INTENTIONAL!

According to a recent discussion with Video Production Manager, Dan Mihoerck:

"This is NOT intentional (has to do with the new CBS video player back end we are using) and they are looking to resolve really soon."

We appreciate your understanding during this time and as always if you have any questions you're welcome to the fabulous females of the Community Team.

#1 Edited by PumpkinBoogie (3357 posts) -

Cool, that makes me feel a bit better, lol. I thought y'all was trying punish us AB users. XD

I have chosen to occasionally (temporarily) disable on the video part of the site, when there's a video I want to see. So it's a quasi-work around that works for me.

#2 Posted by Randolph (10174 posts) -

I use Safari and adblock on a Macbook Pro, and vids all run just fine.

#3 Posted by Aryan1374 (1 posts) -

Hi

Is There Any Way That I Can Download Videos Now . It Looks Like The Option is Disabled

( I Have A Slow Connection So I Can't Watch The Videos Online )

Thank You

#4 Posted by gamestx (3 posts) -

How to download videos in this new site? Please advise. Downloading game trailers and reviews to watch seemless in HD is one of the main reason I visit this site but seems that the downloading HD video options is gone, there's no longer any reason to visit this site anymore. This site is getting worse and worse.. May stop visiting it soon.

#5 Edited by CptJSparrow (10897 posts) -

Hm, there has to be a way to whitelist the videos without turning off adblock

& no, gamespot no longer has downloads

#6 Edited by CptJSparrow (10897 posts) -

HA I FOUND IT

disabling this filter will allow you to watch all videos on the site.

#7 Edited by Pirate700 (46435 posts) -

HA I FOUND IT

disabling this filter will allow you to watch all videos on the site.

Thank you sir!

#8 Edited by Sky_Stifler (3587 posts) -

I fixed the problem by just updating the Easylist :)

#9 Edited by The666trooper (6 posts) -

HA I FOUND IT

disabling this filter will allow you to watch all videos on the site.

Thanks man! It works perfectly!!

#10 Edited by nciox (3 posts) -

Hello Folks, any workaround on how to download videos?

(i do love watching The Gun Show on the go)

#11 Posted by dogman12602 (43 posts) -

Very simple fix to adblock and adblock plus users with chrome. I think they work pretty much the same, I use adblock plus. But anyway, just simpley remove adblock plus or adblock from your chrome apps and then re-add (re-install) them from the chrome app store. And vuala, No More Commercials!!! Just straight to the video again : P

#12 Edited by PumpkinBoogie (3357 posts) -

@CptJSparrow: Ah, thanks, indeed for the tip! Better than disabiling/enabiling it over and over, lol. Gotta remember this the next time I open Chrome, too.

#13 Edited by DigitalDame (3516 posts) -

Thank you for continuing to update this thread with errors. I've added these to my report and so hopefully we can resolve this issue sooner.

#14 Posted by RobotOpBuddy (64744 posts) -

It would appear easylist (the primary default list for adblock) has removed (well, modified) the filter that caused this from their list themselves, so if you're not using other lists for adblock/ABP that may cause problems it should work fine for you now - well, provided the local copy of the list has updated for you (you can manually force an update check if it hasn't), anyway. if you're using other lists then they may still be blocking it, ad block users with minimal list subscriptions should no longer have an issue once the lists have updated though.

#15 Posted by johnd13 (7378 posts) -

Watched a video just fine earlier. I hope it works for others too.

#16 Posted by DigitalDame (3516 posts) -

UPDATE!
Good news everyone! New code was recently published in an attempt to help better resolve the video player issue. If you were or continue to be impacted by this error please take time to clear your cashe and try again.

If after doing this you are still having issues with our video player please let me know in this thread.

#17 Posted by ferretshob (166 posts) -

@DigitalDame:

Hi,

I am having trouble with the video playback as well but I am not running any adblock or any blocking software. I have posted a bug report and fix issue but no one over a week now has been able to answer or even reply to my question. Can you please help? My orginal post is as follows:

Hi all,

Have been a huge Gamespot.com fan for years and I am finding the new website absolutely awful. I suppose it is something to get used to. When watching a video and clicking on full screen mode, it is only full screen in the webpage. It no longer goes full screen completely. Why?

The video only plays in native ratio and won't even go to 16:9 ratio. I am running windows 7 ultimate and a mac screen with 1920 x 1080 hd display. The videos use to work properly before the update but won't now. My flash player is the current version and I do not have any problems with any other website.

#18 Posted by SteveN (569 posts) -

@ferretshob When you hover over the fullscreen icon in the video player there should be a menu that pops up. Does clicking the fullscreen option make it full screen?

#19 Edited by ferretshob (166 posts) -

@SteveN:

Hi, there is no options when I hover over the fullscreen icon using ie10. However I have just checked this with Chrome and the option is there. I hate using chrome, so does anyone know How I can change this is in ie10?

#20 Posted by ferretshob (166 posts) -

@SteveN:

Hi,

Any luck at all on my question. See below:

Hi, there is no options when I hover over the fullscreen icon using ie10. However I have just checked this with Chrome and the option is there. I hate using chrome, so does anyone know how I can change this is in ie10?

#21 Edited by kamikazeespleen (27 posts) -

A problem I'm having is the video player is really choppy. I mean like 15fps kinda thing considering its supposed to show 60. I didn't have this problem with the last player. Tried disabling AdBlock and this didn't fix it. Any help?

#22 Edited by neprisistates (16 posts) -

I am so disappointed with new design of the website. With these enlarged fonts, blocky squares and dull background it looks like some tablet optimised crap. But I have a desktop!!!

Also whats with this new video player, what was wrong with the old one? where is the option to download videos? even flashgot doesnt work anymore. (but there is a workaround to download vids)

Anyway, dissapointing.

#23 Edited by SteveN (569 posts) -

@ferretshob I'll put this in as a bug so the video guy can take a look.

#24 Posted by DigitalDame (3516 posts) -

#25 Posted by LarkAnderson (1630 posts) -

@kamikazeespleen: Unfortunately, we render fullscreen video using HTML5, which is not something that IE10 supports. This will be coming in IE11 though, but until then, this is not something we can change.

#26 Edited by schmid25 (3 posts) -

I'm not sure why the new video player is not working correctly, but I can't watch any video on this site at all. And no adblocker is not my issue I've tried that. Every single video has been really choppy no matter what I try for the render settings. I never had problems running them at 720p with the old player but this one doesn't even let me watch the videos at all. If this isn't fixed sooner rather than later then I think gamespot will have lot me because I'm not gonna keep coming back to watch this stuff. I really love gamespot and love to come here for news, but this is just a blatant problem that doesn't seem to be getting better in my opinion. FYI I'm on a mac using safari.

#27 Edited by ben_halpin (72 posts) -

Videos don't play past 5 seconds for me, no adblock and I get the same result in chrome and IE. Changing the setting does nothing either :/

#29 Edited by kamikazeespleen (27 posts) -
#30 Edited by Rawandouz (26 posts) -

Hi, videos are not working on my mac os x 10.5.8 with/without adblock, however everything is running fine on my win7 PC I can watch all vids even with adblock on.

thanks for the support mates!

#31 Posted by EvanescentCrow (73 posts) -

UPDATE!

Good news everyone! New code was recently published in an attempt to help better resolve the video player issue. If you were or continue to be impacted by this error please take time to clear your cashe and try again.

If after doing this you are still having issues with our video player please let me know in this thread.

I've noticed the video issue before but I wanted to test some things before jumping the gun.

The fact is, all recent videos work fine for me, even with ad blocker. If I go to the main page and click "Ryse", "GTA5", "BF4" or even search for "Forza 5", they all work fine. However, older video reviews don't play. For instance, "Final Fantasy XII" or "Forza 4" are a no go.

I tried the "trick" mentioned in a post above, by removing ad blocker (Adblock Plus 2.4), closing the browser, reopening it, reinstalling the ad blocker, closing the browser, and reopening it a 2nd time (to make sure it registered, even though the add-on claims to work straight out of the box) and... still no luck. The new videos work, but the older ones simply don't. Clearing cache isn't helpful.

With some experimentation, I realized this is NOT an ad blocker issue because when I selected "Disable on gamespot.com" (on the ad blocker menu), the above mentioned older games run their ad just fine (funny moment as I tried to watch a Forza 4 review, and got a Gran Turismo 6 ad, but I digress). It was after the ad finished that I got... nothing. It just stood there saying my video would start in 00:01, and never did. I tried the same with "Final Fantasy XII" and, again, the ad ran fine, but the video review itself never played (this time the timer said 00:00).

I'm running Firefox 25.0.1, on Windows 7 (x64), fwiw. I'll add this to my feedback thread, too.

Thanks.

#32 Edited by dtrjones (3 posts) -

Hi GS,

I've hit video issues today, don't remember them in the past. I'm using Internet Explorer 11 (set to update automatically) on Windows 7 64 bit. I've removed all add-ons, disabled popup blocking and I've reset security and advance settings but the Flash based videos don't want to play. The video I wanted to play was the Video Review for Grid 2 for the PC. It just says Please use a flash video capable browser to watch videos. I can play flash on other websites no problem.

Thanks.

Cheers,
Dave.

#33 Posted by reg23 (6 posts) -

Hi,

I installed Adblock temporarily and after deleting it, am still unable to watch all videos on the site. Does fixing this require I change something in Internet Explorer 9's settings? Please help.

#34 Posted by Arther-la-Blunt (611 posts) -

Why don't you just let us pay to be ad free? Run a pilot or something to see the level of interest.

#35 Posted by mclayton (9 posts) -

Considering most videos are only a few minutes long, I often watch several one after the other. being forced to endure the same advert again and again is an endurance test I am beginning to fail to the point where I visit the site less than half the time I used to. I understand GS have to make money somehow but if you could make us suffer a maximum of one or two ads per hours viewing it would be much better.