User created review not showing up

This topic is locked from further discussion.

#1 Edited by BasilVZero (1470 posts) -

I posted a review yesterday for Super Mario RPG....it does not show up in my activity field nor on my reviews list....and when I tried submitting another one, it says I already did a review for this object.

Has been more than 24 hrs now - not sure if its a glitch or the system being too slow...though I never had this issue before.

Also the number of reviews I have is wrong as the counter still says "99".

#2 Edited by edgework (318 posts) -

@BasilVZero said:

I posted a review yesterday for Super Mario RPG....it does not show up in my activity field nor on my reviews list....and when I tried submitting another one, it says I already did a review for this object.

Has been more than 24 hrs now - not sure if its a glitch or the system being too slow...though I never had this issue before.

Also the number of reviews I have is wrong as the counter still says "99".

Sorry, It doesn't exist. There must have been a problem saving it. If you were not taken to the page for your review when you saved it, it didn't save likely because you didn't select a release of the game. There's a bug (fixed in tomorrow's release) that didn't notify you of that error.

#3 Posted by BasilVZero (1470 posts) -

@edgework said:

@BasilVZero said:

I posted a review yesterday for Super Mario RPG....it does not show up in my activity field nor on my reviews list....and when I tried submitting another one, it says I already did a review for this object.

Has been more than 24 hrs now - not sure if its a glitch or the system being too slow...though I never had this issue before.

Also the number of reviews I have is wrong as the counter still says "99".

Sorry, It doesn't exist. There must have been a problem saving it. If you were not taken to the page for your review when you saved it, it didn't save likely because you didn't select a release of the game. There's a bug (fixed in tomorrow's release) that didn't notify you of that error.

I went back to see - I cant edit a review and when I add a review it says it already exists.

I chose the US version of Super Mario RPG...dont tell me I have to choose another region now ~__~.