Problem with forums and posting...really need help...

This topic is locked from further discussion.

Avatar image for ShadowsDemon
#1 Edited by ShadowsDemon (9805 posts) -

Hello there, GameSpot Staff and internets.

I don't want to be one of those people whining and gripping about the new site and how awful it looks...but quite frankly I feel you should at least give us the option to revert back to the old style for a number of reasons. (these include glitches and hiccups, not personal preferences)

* the site is too bright - white hurts my eyes. A lot.

* the settings don't always seem to work. I click "save" but then they revert back to the option I had last.

* I can't add games to "My playing" list stack...only my own collection...

* Sigs don't seem to show up.

* I can't seem to follow other people...

* Notifications are delayed.

And most importantly, this:

* Whenever I made a post on the old website I used to be able to go to my posting history, click on the post, and be taken to my post (and all other subsequent unread posts in the thread). Now I can't do that - it just takes me to the thread itself, and I have to trawl through hundreds of posts and dozens of pages to find my post, and do the same thing again to reply to someone else in the thread. I can't even navigate to the last unread post in the thread from the forum takes me to the very last one, not the first unread post.

If this last problem could be solved I would be very happy. I know you guys are busy, but this is a major, major problem (at least for me and a few others). I've been a regular poster for a long time now, and I really like GameSpot, the community, videos, people here, etc. Please don't take that away from me.

Thanks for your time guys. :)

Avatar image for rick
#2 Posted by Rick (913 posts) -

Merged this into pinned topic here.