Known Login Problems - Should be Resolved

This topic is locked from further discussion.

#1 Posted by simonsez112 (22 posts) -

Hi All-

I manage the development team here at CBS Interactive Games.

Yesterday made a change to GameSpot to enable SSL (Secure Socket Layer) login in order to add a layer of security to login, especially for public networks. That change had 2 problems in it which resulted in users not being able to login to GameSpot (if they were not already logged in).

The two problems were:

1. We have a bit of security that prevents users from hacking others by guessing passwords and forces a CAPTCHA image to be displayed on a number of failed login attempts. This security check misfired and caused many users who did not have failed login attempts to receive the CAPTCHA.

2. The CAPTCHA image itself was not loading outside of our networks. This was a big mistake that we did not pick up during our QA process as we were testing through out networks, and we will adjust our testing procedures going forward to account for this.

Both of these problems have been resolved now (we hope!), but if you are still having login problems please email us at community at gamespot.com and we will investigate.

I'm very sorry for this problem, this was our fault and we will work hard to prevent it from recurring.

-simon

#2 Posted by gmax (6861 posts) -
Thanks for the intervention Simon! Cold logins look normal again here.

#3 Posted by Loegi (1692 posts) -
Did you change the allowed password characters to not allow special characters like: #$%^&* etc.? Because my previous password doesn't work anymore, not even after multiple resets. But without including special characters it does work. Not necessarily a problem, but it isn't mentioned when you reset the password, and it just accepts it. You just can't log in with that password.
#4 Posted by simonsez112 (22 posts) -

Did you change the allowed password characters to not allow special characters like: #$%^&* etc.? Because my previous password doesn't work anymore, not even after multiple resets. But without including special characters it does work. Not necessarily a problem, but it isn't mentioned when you reset the password, and it just accepts it. You just can't log in with that password.Loegi

Thanks for reporting that - the characters accepted as valid should not have changed. Was it all of those particular characters that you used? We'll definitely look into this.

#10 Posted by Loegi (1692 posts) -

[QUOTE="Loegi"]Did you change the allowed password characters to not allow special characters like: #$%^&* etc.? Because my previous password doesn't work anymore, not even after multiple resets. But without including special characters it does work. Not necessarily a problem, but it isn't mentioned when you reset the password, and it just accepts it. You just can't log in with that password.simonsez112

Thanks for reporting that - the characters accepted as valid should not have changed. Was it all of those particular characters that you used? We'll definitely look into this.

It didn't work with the & symbol, and I tried it with the $ symbol and that did work.
#11 Posted by cum_ova (55 posts) -

i have login problems

im from australia, always use the US website however it doesnt let me login there anymore, i need to login into the australian website then switch to the US one to be logged...anyone have this issue?

#12 Posted by Wren28 (27811 posts) -

I have log in problems, twice now I've been logged out automatically and when I go to log in it says password is incorrect even though I know for a fact I have put it in correct, forcing me to reset my password.

#13 Posted by KrazzyDJ (460 posts) -
Still not able to login even after resetting the password. I've currently somehow managed to login temporarily but if I logout and login again or login from a different machine, it will throw a login error !!!
#14 Posted by DR-ZMBK (95 posts) -

Hi,

Can you please help me with the problem I have?

I have been having problems logging in for a long time. I had to reset my password several times now (5 times) I think.

I keep getting the invalid password screen every other time I try to log in. It is starting to get annoying.

Please fix this problem and please let me know that my voice was heard.

#15 Posted by JodyR (16412 posts) -

Hi,

Can you please help me with the problem I have?

I have been having problems logging in for a long time. I had to reset my password several times now (5 times) I think.

I keep getting the invalid password screen every other time I try to log in. It is starting to get annoying.

Please fix this problem and please let me know that my voice was heard.

DR-ZMBK

Thanks for following-up. This isn't associated to what Simon is saying above, it's the original bug we reported. Either way, your login history shows that you have had some problems logging in so I've shared this with other staff. Hopefully we can resolve this soon.

#16 Posted by SilentD2 (17 posts) -

having same issue as above

#17 Posted by proevo (22 posts) -

i have an issue also . when i try and log in i cant and only way to do it is to reset password and i can temporarely log in when i log out i cant log in again....and its password reset time again

#18 Posted by Horgen (110151 posts) -
I got the error just now. It did work when I went to the login page though. Also why does gs redirect back and forth between www and us domain?
#19 Posted by doubutsuteki (2905 posts) -

Same here, I have to request a password reset to be able to login.

#20 Posted by kurtven (105 posts) -

I can only login when I reset the password :evil: