I cannot post to E3 swag contest page

This topic is locked from further discussion.

#1 Edited by raydawg2000 (155 posts) -

Whenever i view that page it tells me i need to login. The post button says "Post comment as..." and takes me to login page. I can post just fine on other articles, it correctly detects on logged in. On that page specifically though, i doesn't recognize im logged in. At the top of the screen in the header though, it shows my account info as If I am logged in. I have tried Firefox and Chrome, flushed cache....nothing. HELP!!

#2 Edited by atherworld (3 posts) -

Same here. I'm clearly logged in, but am told to sign in to post my comment. Signing in just takes me back to the main Gamestop Page. I'm guessing this is a special contest for only certain members (Which is not mentioned anywhere)? Probably those who post several times each day?

#3 Posted by Chr0noid (39 posts) -

Same here. I cannot post a comment without it doing that. Very irritating.

#4 Edited by wemmick (50 posts) -

Sorry for the trouble, guys - please hit this page instead, and it should work properly. Thanks!

#5 Posted by atherworld (3 posts) -

Yup. That one works. Thanks :)

#6 Posted by raydawg2000 (155 posts) -

yep works now thanks