Dropdown menus don't work

#1 Posted by 93BlackHawk93 (5388 posts) -

I just got a Windows 8 laptop, configured everything, and I notice that Games, Videos and Community, nor my Profile and my Notifications menu drop the other links, which only happens on this site. I don't get notifications when someone replies me either.

I did what mozilla support suggested but it didn't work.

Anything I can do?

#2 Edited by RobotOpBuddy (65040 posts) -

Sounds like gamespot.com scripts are being blocked (or you're in the mobile view for some reason)

If you're running NoScript or any such similar add-on ensure that *.gamespot.com scripts are allowed to run.

Do you see the WYSIWYG editor with bold/italics/underline/strikethrough/etc buttons when posting? If not then also allow ajax.googleapis.com scripts.

Livefyre used for article comments also requires livefyre.com and fyre.co scripts to be allowed otherwise it may not be able to automatically log you in and/or display comments on articles, but these aren't needed outside of livefyre-provided functionality.

As for reply notifications, check your email and notification settings, if you're still not getting notifications when you expect to (or vice versa) then please post the details in this thread.

#4 Edited by 93BlackHawk93 (5388 posts) -

Sounds like gamespot.com scripts are being blocked (or you're in the mobile view for some reason)

If you're running NoScript or any such similar add-on ensure that *.gamespot.com scripts are allowed to run.

Do you see the WYSIWYG editor with bold/italics/underline/strikethrough/etc buttons when posting? If not then also allow ajax.googleapis.com scripts.

Livefyre used for article comments also requires livefyre.com and fyre.co scripts to be allowed otherwise it may not be able to automatically log you in and/or display comments on articles, but these aren't needed outside of livefyre-provided functionality.

As for reply notifications, check your email and notification settings, if you're still not getting notifications when you expect to (or vice versa) then please post the details in this thread.

Nothing's wrong with the scripts.

What's that about mobile view?

#5 Edited by RobotOpBuddy (65040 posts) -

There's an alternate layout for smaller resolutions, designed for mobiles - which doesn't support hover drop-downs and the like.

The easiest way to check which view you're in is to zoom in the browser page a significant amount - if the top bar layout changes in the process then it'll change to the mobile view, if it doesn't change then chances are you're already in it, in which case you have to click on the little triangles on the far right side of each button in order to make the drop-downs appear, with a button with a triple bar symbol on it giving access to the bulk of the menu initially. There are a number of known issues with the mobile site in general as well. If it does change then zooming back out or resetting zoom with ctrl+0 should bring you back to to the desktop version of the site.

-

If you're not in mobile view then try restarting firefox with add-ons disabled (you can do this by selecting restart with add-ons disabled option under help in the main menu, which can be access by pressing the alt button while in firefox if it is hidden) and seeing if it works with all add-ons disabled. If that fixes it then the cause is almost certainly an add-on, just a matter of trial and error to narrow it down in that case.

Does your laptop have a touchscreen installed? While I'm not aware of any GS-specific cases, touchscreens have been known to cause issues (even when just being installed in device manager and not actually in use) with hover in browsers at times, which would cause the symptoms you mention. Setting dom.w3c_touch_events.enabled to 0 in Firefox settings in theory should correct this without uninstalling the touchscreen via device manager, but unfortunately it doesn't seem to help in many cases in practice.

-

If none of that helps then more details would be useful to try and reproduce this:

Windows 8 or 8.1?

Browser, including version number - you mentioned Mozilla support but Mozilla have several different browsers.

A screenshot may be helpful as there may be less obvious things on the page that point towards the issue, and also to ensure that the symptoms match up entirely when trying to replicate it.

#6 Edited by 93BlackHawk93 (5388 posts) -

@robotopbuddy I tried everything. Didn't work

I'm using Windows 8.1 with the latest version of Firefox.

I think I'm on mobile view, but I don't know what option to click in the triple bar symbol for the lists to appear.

There's a touchscreen installed with dom.w3c_touch_events.enabled at 0.

#7 Posted by NeverMore0 (979 posts) -

I'm in the same boat BlackHawk. The drop-down menus work on my Windows 7 desktop, but not on my Windows 8.1 laptop with touchscreen. Both run the newest version of Firefox. Clicking on the little triangles does not open the menus. I don't have this problem with any other site.

#8 Edited by RobotOpBuddy (65040 posts) -

That's the normal view, not the mobile one, so it's simply your computer not currently working properly with :hover, seemingly ignoring it completely (this doesn't come as a surprise, as touch-screens don't actually support :hover in a reasonable manner at all, and can interfere with mouse interactions by simply being enabled); as there's a touch-screen installed there's a good chance that disabling 'HID-compliant touch screen' in the windows device manager program can fix it. This doesn't uninstall the drivers or anything like that and you can just as easily re-enable it but it will effectively change the touch screen into a plain screen while it is disabled.

In 8.1 there's 2 fast ways of opening up the device manager it seems: Via the power user shortcut (Windows+X is the hotkey to open it) and via simply right clicking the start button. There is a process to bring it up via touchscreen gestures, but it's a much longer process and obviously you'll be wanting the HID-compliant touch screen enabled if you're actively using it anyway. As such, this is only a solution if you're not actively using the touch screen but instead favouring a keyboard&mouse.

If this is actually the cause of the issue but you want to keep the touch screen enabled, then a work-around of sorts would be zoom in via ctrl&mouse wheel forwards or ctrl&+ or via the zoom option in the browser (for firefox this is under view>zoom in the main menu). After zooming in enough (the higher your screen resolution the more you'll have to zoom in) it should change to the mobile view, and there'll be a triple bar button in the top left corner of the page, it's quite large as it's designed for small screen resolutions; clicking/tapping that should bring up a menu including the games/video/community drop downs with triangles to the right of those 3 that use click-based functionality instead of hover, which should work fine. The mobile site appears to be designed with touch-screens in mind in general, likely due to the prevalence of touch-screen phones.

#10 Edited by 93BlackHawk93 (5388 posts) -

@robotopbuddy: I disabled HID-compliant touch screen.

It works now! :)