Difficulties when updating profile info

This topic is locked from further discussion.

#1 Posted by ChristianKiss (324 posts) -

Good evening every one.

I uploaded months ago a new Duke avatar and everything works fine, except to comments and forum posts, which still show my old SC2 roach avatar. I tried to upload again but it didn't work.

Also, I can't update my personal information such as Street Address and Zip Postal Code. I type the new info and, when I click on Apply Changes, it seems to reset to the last content.

Is there some way to correct those issues?

Thanks in advance.

#2 Posted by Scalper (437 posts) -
#3 Posted by ChristianKiss (324 posts) -

Thank you for trying to help me out. Actually, after uploading the image again, the problem about my outdated user icon in the forums is solved. Thank you very much!

Yet my problem with the Zip Postal Code and Address still happens. I can't update them through Fuse options, only with the usual GameSpot interface. Anyone experienced this issue? Thanks in advance!

#4 Posted by Scalper (437 posts) -

Yea sorry I didn't see you couldn't update the address from fuse, just the city and zip code. I guess you will have to contact support.

Click http://www.gamespot.com/support then click on SUBMIT A QUESTION

#5 Posted by ChristianKiss (324 posts) -

OK. Thank you very much for your support. I'll submit a question to them.