How to fix frame stutter in Far Cry 3

#1 Posted by DomenicMate (1 posts) -
Hey guys, I know many of you are experiencing frame stuttering in Far Cry 3 for PC and I have found a solution which reduces it significantly - we'll just have to wait until AMD and NVIDIA release new drivers! Anyway, here's the link to the video where I explain how it's done: http://www.youtube.com/watch?v=iuXeDNKjsp8 I hope this helps! The game is actually playable now!
#2 Posted by Jimmy191280 (20 posts) -

After hours and hours of banging my head against the wall trying to find a fix for this stutter problem, I believe I have finally found the solution...

To fix the stutter completely
1. In the Nvidia Control Panel you must set the Far Cry 3 specific settings (under Program Settings) to force Vsync Off.
2. Install Geforce Experience (http://www.geforce.com/drivers/geforce-experience) and use the "optimise game" option.

I used to have the worst video stutter and now it is completely gone.