AC3L bug. Trading ship stuck at Seville. Anyone got the same problem? :(

#1 Posted by V-Angelus2936 (25 posts) -

i got this bug when i was trying to earn some more money using the trading ships. so i got some cotton-filled ship and sent it to seville from bridgetown but after some 40mins of its travel, i returned to check it out and now i see this weird thing that it is stuck at its closest point to seville now i cant even access it. there's not even a countdown timer anymore. i tried checking both seville and bridgetown but no ship was accessible. its simply stuck out there. i tried to send another empty ship to seville but now its also stuck out there. anyone also had the same problem? here a pic, the one stuck is at sevillethe bug i was saying

#2 Posted by V-Angelus2936 (25 posts) -


#3 Posted by mattwillis30 (25 posts) -
I had that problem before my game data corrupted. The only way to get rid is a complete wipe of data. Hold on the game icon on the home menu. Click on the "..." And them delete all data. U can then re-update the game once more but it will still contain other data loss bugs until its patches again. Check out other forums on here and on the official playstation forums. It's a joke
#4 Posted by mattwillis30 (25 posts) -

Ubisoft - more like "u b sh1te"

#5 Posted by Chip6007 (25 posts) -
I'm having the same issue. I bought multiple ships, but I am only able to see and send one from one harbor to another. The others are shown at ports but do not appear on the map. Travel timer is constantly resetting on one of the ships to Seville.